HDU_2031——十进制转换成R进制

时间:2021-07-02 15:37:17
Problem Description
输入一个十进制数N,将它转换成R进制数输出。
 
Input
输入数据包含多个测试实例,每个测试实例包含两个整数N(32位整数)和R(2<=R<=16, R<>10)。
 
Output
为每个测试实例输出转换后的数,每个输出占一行。如果R大于10,则对应的数字规则参考16进制(比如,10用A表示,等等)。
 
Sample Input
7 2 23 12 -4 3
 
Sample Output
111 1B -11
 #include <cstdio>
int main()
{
int n,r,i;
const char str[]="0123456789ABCDEF";
char ans[];
while(~scanf("%d%d",&n,&r))
{
i=;
if(n<)
{
n=-n;
printf("-");
}
while(n)
{
ans[i++]=str[n%r];
n=n/r;
}
for(int j=i-;j>=;j--)
{
printf("%c",ans[j]);
}
printf("\n");
}
return ;
}