poj 1160 Post Office (间隔DP)

时间:2021-01-24 15:12:48
Post Office
Time Limit: 1000MS   Memory Limit: 10000K
Total Submissions: 15966   Accepted: 8671

Description

There is a straight highway with villages alongside the highway. The highway is represented as an integer axis, and the position of each village is identified with a single integer coordinate. There are no two villages in the same position. The distance between
two positions is the absolute value of the difference of their integer coordinates. 



Post offices will be built in some, but not necessarily all of the villages. A village and the post office in it have the same position. For building the post offices, their positions should be chosen so that the total sum of all distances between each village
and its nearest post office is minimum. 



You are to write a program which, given the positions of the villages and the number of post offices, computes the least possible sum of all distances between each village and its nearest post office. 

Input

Your program is to read from standard input. The first line contains two integers: the first is the number of villages V, 1 <= V <= 300, and the second is the number of post offices P, 1 <= P <= 30, P <= V. The second line contains V integers in increasing
order. These V integers are the positions of the villages. For each position X it holds that 1 <= X <= 10000.

Output

The first line contains one integer S, which is the sum of all distances between each village and its nearest post office.

Sample Input

10 5
1 2 3 6 7 9 11 22 44 50

Sample Output

9

题意:在v个村庄中建立p个邮局。求全部村庄到它近期的邮局的距离和。村庄在一条直线上。邮局建在村庄上。

思路:首先求出在连续的几个村庄上建立一个邮局的最短距离,用数组dis[i][j]表示在第i个村庄和第j个村庄之间建一个邮局的最短距。

dis[i][j]=dis[i][j-1]+x[j]-x[(i+j)/2]; (村庄位置为x[i])

用数组dp[i][j]表示在前i个村庄中建立j个邮局的最小距离。即在前k(k<i)个村庄建立j-1个邮局,在k+1到j个村庄建立一个邮局。

dp[i][j]=min(dp[i][j],dp[k][j-1]+dis[k+1][i])

#include<stdio.h>
#include<math.h>
#include<string.h>
#include<stdlib.h>
#include<algorithm>
using namespace std;
#define N 305
const int inf=0x3fffffff;
int dp[N][35]; //在前i个村庄中建立j个邮局的最小耗费
int dis[N][N];//dis[i][j]:第i个村庄到第j个村庄建一个邮局的最短距离
int x[N]; //村庄位置
int main()
{
int v,p,i,j,k;
while(scanf("%d%d",&v,&p)!=-1)
{
for(i=1;i<=v;i++)
scanf("%d",&x[i]);
//memset(dis,0,sizeof(dis));
for(i=1;i<=v;i++)
{
for(j=i+1;j<=v;j++)
{
dis[i][j]=dis[i][j-1]+x[j]-x[(i+j)/2];
}
}
for(i=1;i<=v;i++)
{
dp[i][i]=0; //一个村庄一个邮局距离为零
dp[i][1]=dis[1][i]; //前i个村庄建立一个邮局
}
for(j=2;j<=p;j++)
{
for(i=j+1;i<=v;i++)
{
dp[i][j]=inf;
for(k=j-1;k<i;k++)
{
dp[i][j]=min(dp[i][j],dp[k][j-1]+dis[k+1][i]);
}
}
}
printf("%d\n",dp[v][p]);
}
return 0;
}


版权声明:本文博客原创文章。博客,未经同意,不得转载。