SDUT-串结构练习——字符串连接

时间:2021-01-08 15:09:07

串结构练习——字符串连接

Time Limit: 1000MS Memory Limit: 65536KB

Problem Description

 给定两个字符串string1和string2,将字符串string2连接在string1的后面,并将连接后的字符串输出。
连接后字符串长度不超过110。 

Input

 输入包含多组数据,每组测试数据包含两行,第一行代表string1,第二行代表string2。
 

Output

 对于每组输入数据,对应输出连接后的字符串,每组输出占一行。 

Example Input

123
654
abs
sfg

Example Output

123654
abssfg

Hint

 
#include <bits/stdc++.h>
#include <string.h>
using namespace std;
int main()
{
char st1[1111],st2[1111];
while(scanf("%s",st1)!=EOF)
//gets(st1);
{
scanf("%s",st2);
strcat(st1,st2);//注意字符串连接函数的使用
printf("%s\n",st1);
}
return 0;
}