InputThe input file contains one or more grids. Each grid begins with a line containing m and n, the number of rows and columns in the grid, separated by a single space. If m = 0 it signals the end of the input; otherwise 1 <= m <= 100 and 1 <= n <= 100. Following this are m lines of n characters each (not counting the end-of-line characters). Each character corresponds to one plot, and is either `*', representing the absence of oil, or `@', representing an oil pocket.
OutputFor each grid, output the number of distinct oil deposits. Two different pockets are part of the same oil deposit if they are adjacent horizontally, vertically, or diagonally. An oil deposit will not contain more than 100 pockets.
Sample Input
1 1
*
3 5
*@*@*
**@**
*@*@*
1 8
@@****@*
5 5
****@
*@@*@
*@**@
@@@*@
@@**@
0 0
Sample Output
0
1
2
2
#include <bits/stdc++.h>
using namespace std;
#define M 102 char map1[M][M];
int vis[M][M];
int m,n,sum;
int dir[8][2] = {{1,0},{1,1},{0,1},{-1,1},{-1,0},{-1,-1},{0,-1},{1,-1}}; void dfs(int x, int y){
for(int i = 0; i < 8; i++)
{
int dx = x + dir[i][0];
int dy = y + dir[i][1];
if(dx >= 0 && dy >= 0 && dx < m && dy < n && map1[dx][dy] == '@' && !vis[dx][dy]){
vis[dx][dy] = 1;
dfs(dx,dy);
}
}
return;
} int main(){
while(cin>>m>>n && m && n){
memset(vis,0,sizeof(vis));
sum = 0;
getchar();
for(int i = 0; i < m; i++)
scanf("%s",map1[i]);
for(int i = 0; i < m; i++)
for(int j = 0; j < n; j++)
if(map1[i][j] == '@' && !vis[i][j]){
sum++;dfs(i,j);
}
cout<<sum<<endl;
}
return 0;
}