Balloon Comes!
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 26455 Accepted Submission(s): 10055
Problem Description
The contest starts now! How excited it is to see balloons floating around. You, one of the best programmers in HDU, can get a very beautiful balloon if only you have solved the very very very... easy problem.
Give you an operator (+,-,*, / --denoting addition, subtraction, multiplication, division respectively) and two positive integers, your task is to output the result.
Is it very easy?
Come on, guy! PLMM will send you a beautiful Balloon right now!
Good Luck!
Give you an operator (+,-,*, / --denoting addition, subtraction, multiplication, division respectively) and two positive integers, your task is to output the result.
Is it very easy?
Come on, guy! PLMM will send you a beautiful Balloon right now!
Good Luck!
Input
Input contains multiple test cases. The first line of the input is a single integer T (0<T<1000) which is the number of test cases. T test cases follow. Each test case contains a char C (+,-,*, /) and two integers A and B(0<A,B<10000).Of course, we all know that A and B are operands and C is an operator.
Output
For each case, print the operation result. The result should be rounded to 2 decimal places If and only if it is not an integer.
Sample Input
4
+ 1 2
- 1 2
* 1 2
/ 1 2
Sample Output
3
-1
2
0.50
分析:简单题,只要注意除法的时候,如果能整除则直接输出就行,否则保留两位小数
#include <iostream>
#include <cstdio>
using namespace std; int main(){
char c;
int t, a, b;
cin >> t;
while(t--){
cin >> c >> a >> b;
if(c == '+')
cout << (a + b) << endl;
else if(c == '-')
cout << (a - b) << endl;
else if(c == '*')
cout << (a * b) << endl;
else if(c == '/'){
if(a % b == )
cout << (a / b) << endl;
else
printf("%.2f\n", (float)a / b);
}
}
return ;
}