PAT - 1004. 成绩排名 (20)

时间:2022-02-10 06:53:12

读入n名学生的姓名、学号、成绩,分别输出成绩最高和成绩最低学生的姓名和学号。

输入格式:每个测试输入包含1个测试用例,格式为

  第1行:正整数n
第2行:第1个学生的姓名 学号 成绩
第3行:第2个学生的姓名 学号 成绩
... ... ...
第n+1行:第n个学生的姓名 学号 成绩
其中姓名和学号均为不超过10个字符的字符串,成绩为0到100之间的一个整数,这里保证在一组测试用例中没有两个学生的成绩是相同的。

输出格式:对每个测试用例输出2行,第1行是成绩最高学生的姓名和学号,第2行是成绩最低学生的姓名和学号,字符串间有1空格。

输入样例:
3
Joe Math990112 89
Mike CS991301 100
Mary EE990830 95
输出样例:
Mike CS991301
Joe Math990112
#include <iostream>
#include <string>
using namespace std;

int main()
{
int n=0;
cin>>n;
string t1,t2,t3,t4,t5,t6;
int score1=0,score2=0,score3=0;
cin>>t1>>t2>>score1;
t5=t1;
t6=t2;
score3=score1;
while (n>0)
{
if (cin>>t3>>t4>>score2)
{

if (score2>score1)
{
t1=t3;
t2=t4;
score1=score2;
}
if (score2<score3)
{
t5=t3;
t6=t4;
score3=score2;
}
}
n--;
}
cout<<t1<<' '<<t2<<endl;
cout<<t5<<' '<<t6<<endl;
system("pause");
return 0;
}