-
描述
-
把一个字符串中所有出现的大写字母都替换成小写字母,同时把小写字母替换成大写字母。
-
输入
-
输入一行:待互换的字符串。
-
输出
-
输出一行:完成互换的字符串(字符串长度小于80)。
-
样例输入
-
If so, you already have a Google Account. You can sign in on the right.
-
样例输出
-
iF SO, YOU ALREADY HAVE A gOOGLE aCCOUNT. yOU CAN SIGN IN ON THE RIGHT.
-
提示
-
由于输入字符串中有空格,因此应该用get(s)把一行字符串读入到字符数组s中。
可用printf("%s\n",s)输出字符串s。
-
import java.util.Scanner;
public class Main {
public static void main(String[] args) {
Scanner sc=new Scanner(System.in);
String s1="abcdefghijklmnopqrstuvwxyz";
String s2="ABCDEFGHIJKLMNOPQRSTUVWXYZ";
String s3=sc.nextLine();
int len=s3.length();
for(int i=0;i<len;i++){
int a=s1.indexOf(s3.charAt(i));
int b=s2.indexOf(s3.charAt(i));
if(a==-1&&b==-1){
System.out.print(s3.charAt(i));
}
if(a==-1&&b!=-1){
System.out.print(s1.charAt(b));
}
if(a!=-1&&b==-1){
System.out.print(s2.charAt(a));
}
}
}
}