B - Poor Warehouse Keeper
Time Limit:1000MS Memory Limit:32768KB 64bit IO Format:%I64d & %I64u
Appoint description:
System Crawler (2014-10-09)
System Crawler (2014-10-09)
Description
Jenny is a warehouse keeper. He writes down the entry records everyday. The record is shown on a screen, as follow:
![2013nanjignB 2013nanjignB](https://image.shishitao.com:8440/aHR0cDovL2FjbS5oZHUuZWR1LmNuL2RhdGEvaW1hZ2VzL0M0ODgtMTAwMi0xLmpwZw%3D%3D.jpg?w=700&webp=1)
There are only two buttons on the screen. Pressing the button in the first line once increases the number on the first line by 1. The cost per unit remains untouched. For the screen above, after the button in the first line is pressed, the screen will be:
![2013nanjignB 2013nanjignB](https://image.shishitao.com:8440/aHR0cDovL2FjbS5oZHUuZWR1LmNuL2RhdGEvaW1hZ2VzL0M0ODgtMTAwMi0yLmpwZw%3D%3D.jpg?w=700&webp=1)
The exact total price is 7.5, but on the screen, only the integral part 7 is shown.
Pressing the button in the second line once increases the number on the second line by 1. The number in the first line remains untouched. For the screen above, after the button in the second line is pressed, the screen will be:
![2013nanjignB 2013nanjignB](https://image.shishitao.com:8440/aHR0cDovL2FjbS5oZHUuZWR1LmNuL2RhdGEvaW1hZ2VzL0M0ODgtMTAwMi0zLmpwZw%3D%3D.jpg?w=700&webp=1)
Remember the exact total price is 8.5, but on the screen, only the integral part 8 is shown.
A new record will be like the following:
![2013nanjignB 2013nanjignB](https://image.shishitao.com:8440/aHR0cDovL2FjbS5oZHUuZWR1LmNuL2RhdGEvaW1hZ2VzL0M0ODgtMTAwMi00LmpwZw%3D%3D.jpg?w=700&webp=1)
At that moment, the total price is exact 1.0.
Jenny expects a final screen in form of:
![2013nanjignB 2013nanjignB](https://image.shishitao.com:8440/aHR0cDovL2FjbS5oZHUuZWR1LmNuL2RhdGEvaW1hZ2VzL0M0ODgtMTAwMi01LmpwZw%3D%3D.jpg?w=700&webp=1)
Where x and y are previously given.
What’s the minimal number of pressing of buttons Jenny needs to achieve his goal?
![2013nanjignB 2013nanjignB](https://image.shishitao.com:8440/aHR0cDovL2FjbS5oZHUuZWR1LmNuL2RhdGEvaW1hZ2VzL0M0ODgtMTAwMi0xLmpwZw%3D%3D.jpg?w=700&webp=1)
There are only two buttons on the screen. Pressing the button in the first line once increases the number on the first line by 1. The cost per unit remains untouched. For the screen above, after the button in the first line is pressed, the screen will be:
![2013nanjignB 2013nanjignB](https://image.shishitao.com:8440/aHR0cDovL2FjbS5oZHUuZWR1LmNuL2RhdGEvaW1hZ2VzL0M0ODgtMTAwMi0yLmpwZw%3D%3D.jpg?w=700&webp=1)
The exact total price is 7.5, but on the screen, only the integral part 7 is shown.
Pressing the button in the second line once increases the number on the second line by 1. The number in the first line remains untouched. For the screen above, after the button in the second line is pressed, the screen will be:
![2013nanjignB 2013nanjignB](https://image.shishitao.com:8440/aHR0cDovL2FjbS5oZHUuZWR1LmNuL2RhdGEvaW1hZ2VzL0M0ODgtMTAwMi0zLmpwZw%3D%3D.jpg?w=700&webp=1)
Remember the exact total price is 8.5, but on the screen, only the integral part 8 is shown.
A new record will be like the following:
![2013nanjignB 2013nanjignB](https://image.shishitao.com:8440/aHR0cDovL2FjbS5oZHUuZWR1LmNuL2RhdGEvaW1hZ2VzL0M0ODgtMTAwMi00LmpwZw%3D%3D.jpg?w=700&webp=1)
At that moment, the total price is exact 1.0.
Jenny expects a final screen in form of:
![2013nanjignB 2013nanjignB](https://image.shishitao.com:8440/aHR0cDovL2FjbS5oZHUuZWR1LmNuL2RhdGEvaW1hZ2VzL0M0ODgtMTAwMi01LmpwZw%3D%3D.jpg?w=700&webp=1)
Where x and y are previously given.
What’s the minimal number of pressing of buttons Jenny needs to achieve his goal?
Input
There are several (about 50, 000) test cases, please process till EOF.
Each test case contains one line with two integers x(1 <= x <= 10) and y(1 <= y <= 10 9) separated by a single space - the expected number shown on the screen in the end.
Each test case contains one line with two integers x(1 <= x <= 10) and y(1 <= y <= 10 9) separated by a single space - the expected number shown on the screen in the end.
Output
For each test case, print the minimal number of pressing of the buttons, or “-1”(without quotes) if there’s no way to achieve his goal.
Sample Input
1 1
3 8
9 31
3 8
9 31
Sample Output
0
5
11
5
11
#include<iostream>
#include<cstdio>
#include<cstring>
#include<cmath>
#include<algorithm>
#include<vector>
#define M(a,b) memset(a,b,sizeof(a))
#include<map>
#include<stdlib.h>
#define eps 1e-5
using namespace std; double x,y; int main()
{
while(scanf("%lf%lf",&x,&y)==)
{
double lim = (y+)/x-eps;
double pri = ;
int num = ;
int tim = ;
double all = ;
if(x>y) {puts("-1"); continue;}
while()
{
if(all-y>||fabs(all-y)<eps)
break;
//cout<<lim<<endl;
int tmp = (int)((lim - pri)/(1.0/num));
pri+=tmp*(1.0/num);
//cout<<pri<<' '<<tmp<<endl;
tim+=tmp;
all+= tmp;
if(tmp==)
{
int tm = (int)(1.0/(lim-pri)-num)+;
if(tm>(y+-eps-all)/pri)
tm = (int)((y+-eps-all)/pri);
num+=tm;
tim+=tm;
all+=pri*tm;
}
// cout<<tim<<endl;
//cout<<all<<endl;
}
printf("%d\n",tim);
}
return ;
}