【CodeVS】 p1696 奇怪的函数

时间:2024-11-29 17:05:07
题目描述 Description

自从得到上次的教训后,John的上课态度认真多了,也变得更爱动脑筋了。今天他又学习了一个新的知识:关于 xk 的位数。

如果x大于0小于l,那么位数=1+小数部分×k,

如果x≥l,那么位数=trunc(ln(x)/ln(10)×k)+1+小数部分×k。

根据这些函数知识,他学会了求xk的位数了。但他又想到了另外一个问题,如果已知位数N,能不能求出使得 xk 达到或超过N位数字的最小正整数x是多少?

输入描述 Input Description

输入一个正整数n(n≤2000000000)。

输出描述 Output Description

输出使得 xk 达到n位数字的最小正整数x。

样例输入 Sample Input

11

样例输出 Sample Output

10

思路分析:

换底公式:

log(a)(b)=log(c)(b)/log(c)(a)(a,c均大于零且不等于1)

求位数:

位数

=log(x^x)/ln(10)+1

=x*(log(x)/log(10))

基本二分

Source :

 #include <iostream>
#include <cstdio>
#include <cmath>
#define n 2000000000
using namespace std;
int main()
{
long long m,l,r;
long long a,w;
scanf("%lld",&a);
l=;
r=a*;
while (l<r)
{
//l=1;
// r=n*3;
m=(l+r)/;
w=trunc(log(m)/log()*m)+;
if (w<a)
l=m+;
else
r=m;
}
printf("%lld",l);
return ;
}