Biorhythms
Problem Description
Since the three cycles have different periods, the peaks of the three cycles generally occur at different times. We would like to determine when a triple peak occurs (the peaks of all three cycles occur in the same day) for any person. For each cycle, you will be given the number of days from the beginning of the current year at which one of its peaks (not necessarily the first) occurs. You will also be given a date expressed as the number of days from the beginning of the current year. You task is to determine the number of days from the given date to the next triple peak. The given date is not counted. For example, if the given date is 10 and the next triple peak occurs on day 12, the answer is 2, not 3. If a triple peak occurs on the given date, you should give the number of days to the next occurrence of a triple peak.
Input
Output
Case 1: the next triple peak occurs in 1234 days.
Use the plural form ``days'' even if the answer is 1.
Example Input
0 0 0 0
0 0 0 100
5 20 34 325
4 5 6 7
283 102 23 320
203 301 203 40
-1 -1 -1 -1
Example Output
Case 1: the next triple peak occurs in 21252 days.
Case 2: the next triple peak occurs in 21152 days.
Case 3: the next triple peak occurs in 19575 days.
Case 4: the next triple peak occurs in 16994 days.
Case 5: the next triple peak occurs in 8910 days.
Case 6: the next triple peak occurs in 10789 days.
#include <cstdio>
int main(int argc, const char * argv[]){
int physical, emotional, intellectual, date;
int physicalCycle = , emotionalCycle = , intellectualCycle = , LCM = ;
int caseIndex = ;
while (scanf("%d %d %d %d", &physical, &emotional, &intellectual, &date)) {
if (physical < || emotional < || intellectual < || date <) break;
caseIndex ++;
physical ? physical = physical % physicalCycle : NULL;
emotional ? emotional = emotional % emotionalCycle : NULL;
intellectual ? intellectual = intellectual % intellectualCycle : NULL; int i = , temp;
while () {
temp = i * intellectualCycle + intellectual;
if ((temp % physicalCycle == physical) && (temp % emotionalCycle == emotional)) break;
i++;
}
temp = temp <= date ? temp + LCM : temp;
temp -= date;
printf("Case %d: the next triple peak occurs in %d days.\n", caseIndex, temp);
}
return ;
}//0ms 108kb g++ 1047B