HDU 2602----Bone Collector(0-1背包)

时间:2022-01-31 18:43:15

注意一点:初始化时应该将f[0...V]全部设为0


Problem Description
Many years ago , in Teddy’s hometown there was a man who was called “Bone Collector”. This man like to collect varies of bones , such as dog’s , cow’s , also he went to the grave …
The bone collector had a big bag with a volume of V ,and along his trip of collecting there are a lot of bones , obviously , different bone has different value and different volume, now given the each bone’s value along his trip , can you calculate out the maximum of the total value the bone collector can get ?
HDU 2602----Bone Collector(0-1背包)

 

Input
The first line contain a integer T , the number of cases.
Followed by T cases , each case three lines , the first line contain two integer N , V, (N <= 1000 , V <= 1000 )representing the number of bones and the volume of his bag. And the second line contain N integers representing the value of each bone. The third line contain N integers representing the volume of each bone.
 

Output
One integer per line representing the maximum of the total value (this number will be less than 2 31).
 

Sample Input
 
 
1 5 10 1 2 3 4 5 5 4 3 2 1
 

Sample Output
 
 
14
<pre name="code" class="cpp">#include<stdio.h>
#include<string.h>
int max(int a,int b)
{
	return a>b?a:b;
}
int main(void)
{
	int w[1005],p[1005],dp[1005];
	int T;
	scanf("%d",&T);
	while(T--)
	{
		int n,v;
		scanf("%d%d",&n,&v);
		for(int i=1;i<=n;i++) scanf("%d",&p[i]);
		for(int i=1;i<=n;i++) scanf("%d",&w[i]);
		memset(dp,0,sizeof(dp));
		for(int i=1;i<=n;i++)
		{
			for(int j=v;j>=w[i];j--)
			{
				dp[j]=max(dp[j],dp[j-w[i]]+p[i]);
			}
		}
		printf("%d\n",dp[v]);
	}
	return 0;
}