hdu3033 I love sneakers! (背包问题变形 每种至少买一个)

时间:2022-09-24 18:42:23

转载请注明出处:http://blog.csdn.net/u012860063

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=3033


Problem Description
After months of hard working, Iserlohn finally wins awesome amount of scholarship. As a great zealot of sneakers, he decides to spend all his money on them in a sneaker store.
hdu3033 I love sneakers! (背包问题变形 每种至少买一个)

There are several brands of sneakers that Iserlohn wants to collect, such as Air Jordan and Nike Pro. And each brand has released various products. For the reason that Iserlohn is definitely a sneaker-mania, he desires to buy at least one product for each brand.
Although the fixed price of each product has been labeled, Iserlohn sets values for each of them based on his own tendency. With handsome but limited money, he wants to maximize the total value of the shoes he is going to buy. Obviously, as a collector, he won’t buy the same product twice.
Now, Iserlohn needs you to help him find the best solution of his problem, which means to maximize the total value of the products he can buy.
 
Input
Input contains multiple test cases. Each test case begins with three integers 1<=N<=100 representing the total number of products, 1 <= M<= 10000 the money Iserlohn gets, and 1<=K<=10 representing the sneaker brands. The following N lines each represents a product with three positive integers 1<=a<=k, b and c, 0<=b,c<100000, meaning the brand’s number it belongs, the labeled price, and the value of this product. Process to End Of File.
 
Output
For each test case, print an integer which is the maximum total value of the sneakers that Iserlohn purchases. Print "Impossible" if Iserlohn's demands can’t be satisfied.
 
Sample Input
 
 
5 10000 3 1 4 6 2 5 7 3 4 99 1 55 77 2 44 66
 
Sample Output
 
 
255


题意:

一个人去买鞋,有k种牌子,每种牌子至少买一双鞋子。每双鞋子有标价跟实际价值。求用m多的钱买最多价值的鞋。

n: 物品总数 ,MM: 钱数, KK: 牌子数  ,描述 k:牌号 , mm:标价, vv:价值


代码如下:

#include <cstdio>
#include <cstring>
int max(int A,int B,int C)
{
    return A>B?(A>C?A:C):(B>C?B:C);
}
struct M
{
    int m,v;
} m[17][147];
int main()
{
    int i,j,k,KK,N,MM;
    int num[147],dp[11][10047];
    int vv,mm;
    while(~scanf("%d%d%d",&N,&MM,&KK))
    {
        memset(num,0,sizeof(num));
        memset(dp,-1,sizeof(dp));
        for(i = 0 ; i < N ; i++)
        {
            scanf("%d%d%d",&k,&mm,&vv);
            m[k][num[k]].m = mm;
            m[k][num[k]].v = vv;
            num[k]++;
        }
        for( i = 0 ; i <= MM ; i++)
        {
            dp[0][i] = 0;
        }
        for(k = 1 ; k <= KK ; k++)
        {
            for( i = 0 ; i < num[k] ; i++)
            {
                for(j  = MM ; j >= m[k][i].m ; j--)
                {
                    dp[k][j] = max(dp[k][j],dp[k][j-m[k][i].m]+m[k][i].v,dp[k-1][j-m[k][i].m]+m[k][i].v);
                }
            }
        }
        if(dp[KK][MM] == -1)
            printf("Impossible\n");
        else
            printf("%d\n",dp[KK][MM]);
    }
    return 0;
}