HDU1542 Atlantis 扫描线 矩形面积并

时间:2021-11-14 18:38:10

HDU1542 Atlantis 扫描线 矩形面积并

Description

There are several ancient Greek texts that contain descriptions of the fabled island Atlantis. Some of these texts even include maps of parts of the island. But unfortunately, these maps describe different regions of Atlantis. Your friend Bill has to know the total area for which maps exist. You (unwisely) volunteered to write a program that calculates this quantity.

Input

The input file consists of several test cases. Each test case starts with a line containing a single integer n (1<=n<=100) of available maps. The n following lines describe one map each. Each of these lines contains four numbers x1;y1;x2;y2 (0<=x1

Output

For each test case, your program should output one section. The first line of each section must be “Test case #k”, where k is the number of the test case (starting with 1). The second one must be “Total explored area: a”, where a is the total explored area (i.e. the area of the union of all rectangles in this test case), printed exact to two digits to the right of the decimal point.

Output a blank line after each test case.

Sample Input
2
10 10 20 20
15 15 25 25.5
0
Sample Output
Test case #1
Total explored area: 180.00
HINT

题解

题目大意 给定几个矩形,求其总面积。
矩形面积并的模板题。
HDU1542 Atlantis 扫描线 矩形面积并
我们可以把横/纵(这里以离散横坐标为例)坐标离散化,再用线段树维护横着的边的覆盖情况。
HDU1542 Atlantis 扫描线 矩形面积并
从下面往上面扫描,遇到矩形的下边就给横着的区间加上1,遇到上边就给其减去1,这样每扫到一条横边,将值大于等于1的区间乘以扫描的高加给答案就可以了。
HDU1542 Atlantis 扫描线 矩形面积并
HDU1542 Atlantis 扫描线 矩形面积并
由于线段树只有区间加,我们可以打标记永久化来降低常数。

#include <cstdio>
#include <iostream>
#include <cmath>
#include <stack>
#include <algorithm>
#include <cstring>
#include <climits>
#define MAXN 100000+10
#define M(a) memset(a,0,sizeof(a))
#define LL long long
using namespace std;
struct Line{
double l,r,h;
int d;
}line[MAXN];
bool cmp(const Line a,const Line b) { return a.h<b.h; }
int n,ln,xn,mark[MAXN<<2],t;
double X[MAXN],sum[MAXN<<2],ans;
void pushup(int rt,int l,int r)
{
if(mark[rt]) sum[rt]=X[r+1]-X[l];
else if(l==r) sum[rt]=0;
else sum[rt]=sum[rt<<1]+sum[rt<<1|1];
}
void build(int rt,int l,int r)
{
if(l==r)
{
mark[rt]=0;
sum[rt]=0;
return ;
}
int m=(l+r)>>1;
build(rt<<1,l,m);
build(rt<<1|1,m+1,r);
pushup(rt,l,r);
}
void update(int L,int R,int d,int l,int r,int rt)
{
if(L<=l&r<=R)
{
mark[rt]+=d;
pushup(rt,l,r);
return ;
}
int m=(l+r)>>1;
if(L<=m) update(L,R,d,l,m,rt<<1);
if(m<R) update(L,R,d,m+1,r,rt<<1|1);
pushup(rt,l,r);
}
void init()
{
M(mark);M(X);M(sum);M(line);
ln=xn=0;ans=0;
}
int main()
{
while(1)
{
++t;
scanf("%d",&n);
if(!n) return 0;
init();
for(int i=1;i<=n;i++)
{
double x1,y1,x2,y2;
scanf("%lf%lf%lf%lf",&x1,&y1,&x2,&y2);
line[++ln].l=x1;line[ln].r=x2;line[ln].h=y1;line[ln].d=1;
line[++ln].l=x1;line[ln].r=x2;line[ln].h=y2;line[ln].d=-1;
X[++xn]=x1;X[++xn]=x2;
}
sort(X+1,X+xn+1);
sort(line+1,line+ln+1,cmp);
xn=unique(X+1,X+xn+1)-X-1;
ans=0;
for(int i=1;i<ln;i++)
{
int l=lower_bound(X+1,X+xn+1,line[i].l)-X,
r=lower_bound(X+1,X+xn+1,line[i].r)-X-1;
update(l,r,line[i].d,1,xn-1,1);
ans+=sum[1]*(line[i+1].h-line[i].h);
}
printf("Test case #%d\n",t);
printf("Total explored area: %.2lf\n\n",ans);
//printf("%.2lf\n",ans);
}
return 0;
}