nyoj 94-cigarettes (分清楚,那一部分的cigarettes是用过的,那一部分是没有用过的)

时间:2024-10-21 21:06:50

94-cigarettes

内存限制:64MB
时间限制:3000ms
特判: No

通过数:13
提交数:20
难度:2

题目描述:

Tom has many cigarettes. We hypothesized that he has n cigarettes and smokes them

one by one keeping all the butts. Out of k > 1 butts he can roll a new cigarette.
Now,do you know how many cigarettes can Tom has?

输入描述:

First input is a single line,it's n and stands for there are n testdata.then there are n lines ,each line contains two integer numbers giving the values of n and k.

输出描述:

For each line of input, output one integer number on a separate line giving the maximum number of cigarettes that Peter can have.

样例输入:

复制
3
4 3
10 3
100 5

样例输出:

5
14
124 C/C++ AC
 #include <iostream>
#include <algorithm>
#include <cstring>
#include <cstdio>
#include <cmath>
#include <stack>
#include <set>
#include <map>
#include <queue>
#include <climits> using namespace std;
const int MAX = 1e6 + ;
int n, a, b; int main()
{
cin >>n;
while (n --)
{
int ans = , temp;
scanf("%d%d", &a, &b); while (a >= b)
{
temp = a / b;
ans += temp * b; // temp * b 表示已经用过的
a = temp + a % b;
}
ans += a;
printf("%d\n", ans);
}
}