CF 363B One Bomb(枚举)

时间:2024-10-14 10:34:02

题目链接: 传送门

One Bomb

time limit per test:1 second     memory limit per test:256 megabytes

Description

You are given a description of a depot. It is a rectangular checkered field of n × m size. Each cell in a field can be empty (".") or it can be occupied by a wall ("*").
You have one bomb. If you lay the bomb at the cell (x, y), then after triggering it will wipe out all walls in the row x and all walls in the column y.
You are to determine if it is possible to wipe out all walls in the depot by placing and triggering exactly one bomb. The bomb can be laid both in an empty cell or in a cell occupied by a wall.

Input

The first line contains two positive integers n and m (1 ≤ n, m ≤ 1000) — the number of rows and columns in the depot field.
The next n lines contain m symbols "." and "" each — the description of the field. j-th symbol in i-th of them stands for cell (i, j). If the symbol is equal to ".", then the corresponding cell is empty, otherwise it equals "" and the corresponding cell is occupied by a wall.

Output

If it is impossible to wipe out all walls by placing and triggering exactly one bomb, then print "NO" in the first line (without quotes).
Otherwise print "YES" (without quotes) in the first line and two integers in the second line — the coordinates of the cell at which the bomb should be laid. If there are multiple answers, print any of them.

Sample Input

3 4
.*..
....
.*..

3 3
..*
.*.
*..

6 5
..*..
..*..
*****
..*..
..*..
..*..

Sample Output

YES
1 2

NO

YES
3 3

思路:

题目大意:在一个矩阵中,是否能用一个炸弹炸掉所有的墙(炸弹以自己为中心呈十字引爆)
To solve this problem we need to calculate two arrays V[] and G[], where V[j] must be equal to the number of walls in the column number j and G[i] must be equal to the number of walls in the row number i. Also let's store the total number of walls in the variable cur.
Now we need to look over the cells. Let the current cell be (x, y). Let's count the value cur — how many walls will destroy the bomb planted in the cell (x, y): cnt = V[y] + G[x]. If the cell (x, y) has a wall we count it twice, so we need to subtract 1 from the cnt. If cur = cnt we found the answer and need to plant the bomb in the cell (x, y).
If there is no such cell we need to print "NO".

#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
int N,M;
int r[1005],c[1005];
char maze[1005][1005];
int cnt = 0;
bool OK()
{
    int sum = 0;
    for (int i = 0; i < N; i++)
    {
        for (int j = 0; j < M; j++)
        {
            sum = r[i]+c[j];
            if (maze[i][j] == '*')
            {
                sum--;
            }
            if (sum == cnt)
            {
                printf("YES\n%d %d\n",i+1,j+1);
                return true;
            }
        }
    }
    return false;
}

int main()
{
    while (~scanf("%d%d",&N,&M))
    {
        cnt = 0;
        memset(maze,0,sizeof(maze));
        memset(r,0,sizeof(r));
        memset(c,0,sizeof(c));
        for (int i = 0; i < N; i++)
        {
            getchar();
            for (int j = 0; j < M; j++)
            {
                scanf("%c",&maze[i][j]);
                if (maze[i][j] == '*')
                {
                    r[i]++;
                    c[j]++;
                    cnt++;
                }
            }
        }
        if (!OK())
            printf("NO\n");
    }
    return 0;
}