HDU 4632 Palindrome subsequence (2013多校4 1001 DP)

时间:2024-10-08 20:34:38

Palindrome subsequence

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 131072/65535 K (Java/Others)
Total Submission(s): 88    Accepted Submission(s): 26

Problem Description
In mathematics, a subsequence is a sequence that can be derived from another sequence by deleting some elements without changing the order of the remaining elements. For example, the sequence <A, B, D> is a subsequence of <A, B, C, D, E, F>.
(http://en.wikipedia.org/wiki/Subsequence)

Given a string S, your task is to find out how many different subsequence of S is palindrome. Note that for any two subsequence X = <Sx1, Sx2, ..., Sxk> and Y = <Sy1, Sy2, ..., Syk> , if there exist an integer i (1<=i<=k) such that xi != yi, the subsequence X and Y should be consider different even if Sxi = Syi. Also two subsequences with different length should be considered different.

Input
The first line contains only one integer T (T<=50), which is the number of test cases. Each test case contains a string S, the length of S is not greater than 1000 and only contains lowercase letters.
Output
For each test case, output the case number first, then output the number of different subsequence of the given string, the answer should be module 10007.
Sample Input
4
a
aaaaa
goodafternooneveryone
welcometoooxxourproblems
Sample Output
Case 1: 1
Case 2: 31
Case 3: 421
Case 4: 960
Source
Recommend
zhuyuanchen520

写的递归形式的DP,

循环写可能会好一些。

各种卡常熟,要优化

/*
* Author:kuangbin
* 1001.cpp
*/ #include <stdio.h>
#include <algorithm>
#include <string.h>
#include <iostream>
#include <map>
#include <vector>
#include <queue>
#include <set>
#include <string>
#include <math.h>
using namespace std;
const int MOD = ;
int dp[][];
int n;
char str[];
int solve(int l,int r)
{
if(l > r)return ;
if(l == r)return dp[l][r] = ;
if(dp[l][r] != -)return dp[l][r];
if(r == l+)
{
if(str[l] == str[r])
return dp[l][r] = ;
else return dp[l][r] = ;
}
dp[l][r] = solve(l+,r)+solve(l,r-);
if(dp[l][r] >= MOD)dp[l][r]-=MOD;
if(str[l]==str[r])
{
dp[l][r] ++;
if(dp[l][r] >= MOD)dp[l][r]-=MOD;
}
else
{
dp[l][r] -= solve(l+,r-);
if(dp[l][r]<)dp[l][r] += MOD;
}
return dp[l][r];
} int main()
{
//freopen("in.txt","r",stdin);
//freopen("out.txt","w",stdout);
int T;
int iCase = ;
scanf("%d",&T);
while(T--)
{
iCase++;
memset(dp,-,sizeof(dp));
scanf("%s",str);
n = strlen(str);
printf("Case %d: %d\n",iCase,solve(,n-));
}
return ;
}