跳跃表基础——POJ 3481 Double Queue

时间:2022-02-25 17:38:11

对应POJ 题目:点击打开链接

Double Queue
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 11768   Accepted: 5349

Description

The new founded Balkan Investment Group Bank (BIG-Bank) opened a new office in Bucharest, equipped with a modern computing environment provided by IBM Romania, and using modern information technologies. As usual, each client of the bank is identified by a positive integer K and, upon arriving to the bank for some services, he or she receives a positive integer priority P. One of the inventions of the young managers of the bank shocked the software engineer of the serving system. They proposed to break the tradition by sometimes calling the serving desk with the lowest priority instead of that with the highest priority. Thus, the system will receive the following types of request:

0 The system needs to stop serving
K P Add client K to the waiting list with priority P
2 Serve the client with the highest priority and drop him or her from the waiting list
3 Serve the client with the lowest priority and drop him or her from the waiting list

Your task is to help the software engineer of the bank by writing a program to implement the requested serving policy.

Input

Each line of the input contains one of the possible requests; only the last line contains the stop-request (code 0). You may assume that when there is a request to include a new client in the list (code 1), there is no other request in the list of the same client or with the same priority. An identifier K is always less than 106, and a priority P is less than 107. The client may arrive for being served multiple times, and each time may obtain a different priority.

Output

For each request with code 2 or 3, the program has to print, in a separate line of the standard output, the identifier of the served client. If the request arrives when the waiting list is empty, then the program prints zero (0) to the output.

Sample Input

2
1 20 14
1 30 3
2
1 10 99
3
2
2
0

Sample Output

0
20
30
10
0

题意:

有3个操作:(1  x   y)表示以y为优先级在队列里插入一对数(x   y),其中每一对数的x和y均不同;(2)表示输出优先级最高的一对数中的x,(3)表示输出优先级最低的一对数中的x;(0)表示退出。


思路:

各种二叉排序树,还有STL里的map,set也可AC,此题已被做烂~,贴下跳跃表。

跳跃表知识(点击打开链接


#include <cstdio>
#include <cstdlib>
#include <cmath>
#include <ctime>
#include <iostream>
const int MAXN=1000+10;
using namespace std;

void InitTime()
{
static int first = 1;
if(first){
first = 0;
srand((unsigned)time(0));
}
}

struct Node
{
int v, k;
Node *next, *down;
};

class SkipList
{
public:
Node *Newlay() //建立新一层
{
Node *s = (Node *)malloc(sizeof(Node));
Node *e = (Node *)malloc(sizeof(Node));
s->k = -inf;
e->k = inf;
s->next = e;
e->next = NULL;
s->down = e->down = NULL;
return s;
}
void Init()
{
layer = 1;
inf = 0x7fffffff;
max_k = -inf;
min_k = inf;
top = Findlay[layer] = Newlay();
}
int Getlay() //按规则选择数据应该在哪层插入
{
int lay = 1;
while(rand()%2 && lay <= layer)
lay++;
return lay;
}
void Insert(int a, int b)
{
if(b > max_k) max_k = b;
if(b < min_k) min_k = b;
Node *p, *s, *s1;
int lay = Getlay();
if(lay > layer){ //要插入的层 > 现有层数
p = Newlay();
Findlay[++layer] = p; //标记层号
p->down = top;
top = p;
}
p = Findlay[lay]; //根据层号直接获取该层头指针
bool ok = 0;
while(p) //向某列插入元素
{
while(p->k < b && p->next->k < b) p = p->next;
s = (Node *)malloc(sizeof(Node));
s->v = a;
s->k = b;
s->next = p->next;
s->down = NULL;
p->next = s;
p = p->down;
if(ok) s1->down = s;
s1 = s;
if(!ok) ok = 1;
}
}
void Delete(bool flag) //flag == 1表示删除最大值
{
int d;
if(flag) d = max_k;
else d = min_k;
if(-inf == d || inf == d){ //说明还没有插入元素
printf("0\n");
return;
}
Node *p = top;
while(p){
while(p->next->k < d)
p = p->next;
if(p->next->k == d){
if(NULL == p->down){ //到达最底层
printf("%d\n", p->next->v);
if(-inf == p->k && inf == p->next->next->k){ //要删除的是最后一个元素,min_k 与 max_k要特殊处理
max_k = -inf; min_k = inf;
}
else{
if(flag) max_k = p->k;
else min_k = p->next->next->k;
}
}
Node *tmp = p->next;
p->next = tmp->next;
free(tmp);
}
p = p->down;
}
}
void Show()
{
Node *p = Findlay[1];
p = p->next;
while(p->k != inf)
{
printf("%d ", p->k);
p = p->next;
}
printf("\n");
}
void Free()
{
Node *p, *q;
int i;
for(i = 1; i <= layer; i++){
p = Findlay[i];
while(p){
q = p->next;
free(p);
p = q;
}
}
}
private:
Node *top, *Findlay[70];
int layer, inf, max_k, min_k;
};

SkipList sl;

int main()
{
//freopen("in.txt","r",stdin);
InitTime();
sl.Init();
int op, a, b;
while(scanf("%d", &op), op)
{
if(1 == op){
scanf("%d%d", &a, &b);
sl.Insert(a, b);
}
else if(2 == op)
sl.Delete(1);
else
sl.Delete(0);
}
sl.Free();
return 0;
}