PAT - 甲级 - 1014. Waiting in Line (30)(STL-queue)

时间:2022-06-30 17:38:11

Suppose a bank has N windows open for service. There is a yellow line in front of the windows which devides the waiting area into two parts. The rules for the customers to wait in line are: 

  • The space inside the yellow line in front of each window is enough to contain a line with M customers. Hence when all the N lines are full, all the customers after (and including) the (NM+1)st one will have to wait in a line behind the yellow line.
  • Each customer will choose the shortest line to wait in when crossing the yellow line. If there are two or more lines with the same length, the customer will always choose the window with the smallest number.
  • Customer[i] will take T[i] minutes to have his/her transaction processed.
  • The first N customers are assumed to be served at 8:00am. 

Now given the processing time of each customer, you are supposed to tell the exact time at which a customer has his/her business done.

For example, suppose that a bank has 2 windows and each window may have 2 custmers waiting inside the yellow line. There are 5 customers waiting with transactions taking 1, 2, 6, 4 and 3 minutes, respectively. At 08:00 in the morning, customer1 is served at window1 while customer2 is served at window2. Customer3 will wait in front of window1 and customer4 will wait in front of window2. Customer5 will wait behind the yellow line.

At 08:01, customer1 is done and customer5 enters the line in front of window1 since that line seems shorter now. Customer2 will leave at 08:02, customer4 at 08:06, customer3 at 08:07, and finally customer5 at 08:10.

Input

Each input file contains one test case. Each case starts with a line containing 4 positive integers: N (<=20, number of windows), M (<=10, the maximum capacity of each line inside the yellow line), K (<=1000, number of customers), and Q (<=1000, number of customer queries).

The next line contains K positive integers, which are the processing time of the K customers.

The last line contains Q positive integers, which represent the customers who are asking about the time they can have their transactions done. The customers are numbered from 1 to K.

Output

For each of the Q customers, print in one line the time at which his/her transaction is finished, in the format HH:MM where HH is in [08, 17] and MM is in [00, 59]. Note that since the bank is closed everyday after 17:00, for those customers who cannot be served before 17:00, you must output "Sorry" instead.

Sample Input
2 2 7 5
1 2 6 4 3 534 2
3 4 5 6 7
Sample Output
08:07
08:06
08:10
17:00
Sorry

给定条件:
1.n个窗口,每个窗口最多服务m个人,k个客户和q个查询
2.给定k个客户的处理时间
3.要查询的客户编号
4.排队的方式:

1.每个窗口最多m个人,如果有没满的窗口,去人数最少的那个窗口
2.如果都不满,并且人数都相同,去编号小的那个窗口
3.如果都满,去那个能最先处理完第一个人的业务的窗口,如果有多个窗口同时处理完成则选择编号较小的那一个

要求:
1.要查询的每个顾客的处理结束时间
求解:
1.用queue模拟每个窗口
2.控制queue内的元素个数
3.在进出队的时候进行相应的数据处理更新


#include <cstdio>
#include <queue>
#define INF 999999999
#define bankStartTime (8 * 3600)
#define bankEndTime (17 * 3600)
using namespace std;

struct Customer {
	int process;
	int endTime;
} cus[1005];

queue<Customer> windows[25];

int queries[1005];
int n, m, k, q;

int main() {
	// initial
	scanf("%d%d%d%d", &n, &m, &k, &q);
	for(int i = 1; i <= k; i++) {
		scanf("%d", &cus[i].process);
		cus[i].process *= 60;
	}
	for(int i = 0; i < q; i++) {
		scanf("%d", &queries[i]);
	}
	Customer start;
	start.process = 0;
	start.endTime = bankStartTime;

	for(int i = 0; i < n; i++) {
		windows[i].push(start);
	}
	// process
	for(int i = 1; i <= k; i++) {
		int minId, minTime = INF, minLen = INF;
		for(int j = 0; j < n; j++) {
			if(windows[j].size() < minLen) { // 较短队列优先
				minTime = windows[j].front().endTime;
				minId = j;
				minLen = windows[j].size();
			} else if(windows[j].size() == minLen) { // 长度相同,最前面的人的离开时间最早优先
				if(windows[j].front().endTime < minTime) {
					minTime = windows[j].front().endTime;
					minId = j;
					minLen = windows[j].size();
				}
			}
			
		}
		cus[i].endTime = windows[minId].back().endTime + cus[i].process;  // 入队
		windows[minId].push(cus[i]);

		if(windows[minId].size() == m+1) { // 出队列
			windows[minId].pop();
		}
	}
	// output
	for(int i = 0; i < q; i++) {
		int id = queries[i];
		if(cus[id].endTime - cus[id].process >= bankEndTime) {
			printf("Sorry\n");
		} else {
			printf("%02d:%02d\n", cus[id].endTime/3600, cus[id].endTime%3600/60);
		}
	}
	return 0;
}