POJ - 2823 Sliding Window (单调队列求解区间最值)

时间:2022-05-04 17:39:27
POJ - 2823
Time Limit: 12000MS   Memory Limit: 65536KB   64bit IO Format: %lld & %llu

 Status

Description

An array of size  n ≤ 10  6 is given to you. There is a sliding window of size  k which is moving from the very left of the array to the very right. You can only see the  k numbers in the window. Each time the sliding window moves rightwards by one position. Following is an example: 
The array is  [1 3 -1 -3 5 3 6 7], and  k is 3.
Window position Minimum value Maximum value
[1  3  -1] -3  5  3  6  7  -1 3
 1 [3  -1  -3] 5  3  6  7  -3 3
 1  3 [-1  -3  5] 3  6  7  -3 5
 1  3  -1 [-3  5  3] 6  7  -3 5
 1  3  -1  -3 [5  3  6] 7  3 6
 1  3  -1  -3  5 [3  6  7] 3 7

Your task is to determine the maximum and minimum values in the sliding window at each position. 

Input

The input consists of two lines. The first line contains two integers  n and  k which are the lengths of the array and the sliding window. There are  n integers in the second line. 

Output

There are two lines in the output. The first line gives the minimum values in the window at each position, from left to right, respectively. The second line gives the maximum values. 

Sample Input

8 3
1 3 -1 -3 5 3 6 7

Sample Output

-1 -3 -3 -3 3 3
3 3 5 5 6 7
 
      
#include <map>
#include <cmath>
#include <vector>
#include <cstdio>
#include <cstring>
#include <algorithm>

#define uint unsigned int
typedef long long LL;
using namespace std;
const int MAXN = 1e6 + 5;
int stamin[MAXN], stamax[MAXN];
LL A[MAXN];
int MinB[MAXN], MaxB[MAXN];
int n, k, x, cnt;
int main() {
	while(~scanf("%d%d", &n, &k)) {
		int top1 = 0, rear1 = 0, top2 = 0, rear2 = 0;
		cnt = 0;
		for(int i = 0; i < n; i ++) {
			scanf("%lld", &A[i]);
			while(rear1 > top1 && A[stamin[rear1 - 1]] > A[i]) rear1 --;
			stamin[rear1 ++] = i;
			while(stamin[top1] < i - k + 1) top1 ++;
			MinB[cnt] = stamin[top1];

			while(rear2 > top2 && A[stamax[rear2 - 1]] < A[i]) rear2 --;
			stamax[rear2 ++] = i;
			while(stamax[top2] < i - k + 1) top2 ++;
			MaxB[cnt ++] = stamax[top2];
		}
		for(int i = k - 1; i < n; i ++) {
			printf("%lld%c", A[MinB[i]], i == n - 1 ? '\n' : ' ');
		}
		for(int i =  k - 1; i < n; i ++) {
			printf("%lld%c", A[MaxB[i]], i == n - 1 ? '\n' : ' ');
		}
	}
	return 0;
}