二叉树的层次遍历
时间限制: 1 Sec 内存限制: 64 MB[ 提交][ 状态][ 我的提交]
题目描述
输入一棵二叉树,你的任务是按从上到下、从左到右的顺序输出各个结点的值。每个结点都按照从根结点到它的移动序列给出(L表示左,R表示右)。在输入中,每个结点的左括号和右括号之间没有空格,相邻结点之间用一个空格隔开。每棵树的输入用一对空括号()结束,这对括号本身不代表一个结点。
如果从根到某个叶结点的路径上有的结点没有在输入中给出,或者输入中给出的结点出现了重叠,则输出-1。结点个数不超过256个。
输入
第1行:1个字符串,表示输入的二叉树,格式如题目所述
输出
第1行:按层次遍历的二叉数的结点顺序。结点编号之间用一个空格分隔,行末没有多余空格。
样例输入
(如果复制到控制台无换行,可以先粘贴到文本编辑器,再复制)
(11,LL) (7,LLL) (8,R) (5,) (4,L) (13,RL) (2,LLR) (1,RRR) (4,RR) ()
样例输出
5 4 8 11 13 4 7 2 1
第一次尝试用指针建树, 注意叶子节点的内存分配(NULL是不可以访问的)。
sscanf(地址1,"%[取值内容](eg:"%[0-9]")",地址2);
要保证地址1包含所取内容,在第一次碰到非取值范围内的值时会立即退出。
#include<iostream>
#include<cstdio>
#include<cstring>
#include<cstdlib>
#include<cmath>
#include<queue>
#include<algorithm>
using namespace std;
struct node{
char c;
int num;
struct node *lch, *rch;
}*treeR;
char p[260], S[260], da[12];
int Ans[260];
queue<node*>q;
node* newnode(){
node *u = (node*)malloc(sizeof(node));
if(u != NULL){
u -> num = 0;
u->lch = u->rch = NULL;
}
return u;
}
int get_data(char *s){
int num = 0;
while(*s != '\0'){
num = num * 10 + *s - '0';
s++;
}
return num;
}
char* find_letter(char *a, char *b){
int lena = strlen(a);
int lenb = strlen(b);
for(int i = 0; i < lena; i++)
if(*(a + i) == *(b))
return a + i + lenb + 1;
return a;
}
bool build_tree(char *s, int data){
node *R = treeR;
int len = strlen(s);
for(int i = 0; i < len; i++){
if(*(s + i) == 'L'){
if(R -> lch == NULL)
R -> lch = newnode();
R = R -> lch;
}
else {
if(R -> rch == NULL)
R -> rch = newnode();
R = R -> rch;
}
}
if(R -> num)return 0;
R -> num = data;
return 1;
}
void print(){
int tot = 0;
q.push(treeR);
while(!q.empty()){
node *tmp = q.front();q.pop();
Ans[++ tot] = tmp -> num;
if(!tmp -> num){
puts("-1");
return ;
}
if(tmp -> lch != NULL)q.push(tmp -> lch);
if(tmp -> rch != NULL)q.push(tmp -> rch);
}
printf("%d", Ans[1]);
for(int i = 2; i <= tot; i++)
printf(" %d", Ans[i]);
putchar(10);
return ;
}
int main(){
treeR = newnode();
while(scanf("%s", S) && S[1] != ')'){
sscanf(S + 1, "%[0-9]", da);//分离数字
sscanf(find_letter(S, da), "%[LR]", p);//分离字母
if(!build_tree(p, get_data(da))){
printf("-1\n");
return 0;
}
memset(S, 0, sizeof(S));
memset(p, 0, sizeof(p));
}
print();
}