PAT甲级——1019 General Palindromic Number

时间:2023-03-08 16:28:15

A number that will be the same when it is written forwards or backwards is known as a Palindromic Number. For example, 1234321 is a palindromic number. All single digit numbers are palindromic numbers.

Although palindromic numbers are most often considered in the decimal system, the concept of palindromicity can be applied to the natural numbers in any numeral system. Consider a number N>0 in base b≥2, where it is written in standard notation with k+1 digits a​i​​ as ∑​i=0​k​​(a​i​​b​i​​). Here, as usual, 0≤a​i​​<b for all i and a​k​​ is non-zero. Then N is palindromic if and only if a​i​​=a​k−i​​ for all i. Zero is written 0 in any base and is also palindromic by definition.

Given any positive decimal integer N and a base b, you are supposed to tell if N is a palindromic number in base b.

Input Specification:

Each input file contains one test case. Each case consists of two positive numbers N and b, where 0<N≤10​9​​ is the decimal number and 2≤b≤10​9​​ is the base. The numbers are separated by a space.

Output Specification:

For each test case, first print in one line Yes if N is a palindromic number in base b, or No if not. Then in the next line, print N as the number in base b in the form "a​k​​ a​k−1​​ ... a​0​​". Notice that there must be no extra space at the end of output.

Sample Input 1:

27 2

Sample Output 1:

Yes
1 1 0 1 1

Sample Input 2:

121 5

Sample Output 2:

No
4 4 1
//General Palindromic Number
#include<stdio.h>
#include<vector>
using namespace std;
vector<int>V;
int main(void){
 int n, b;
 while (scanf("%d%d", &n, &b) != EOF){
  V.clear();
  if (n == 0){//如果是0的话,不论什么进制都是回文数字
   puts("Yes");
   printf("0\n");
   continue;
  }
  while (n){//用V来存储b进制下的各个位数
   V.push_back(n % b);
   n /= b;
  }
  bool result  = true;;
  for (int i = 0; i < V.size(); i++){
   if (V[i] != V[V.size() - i - 1]){
    result = false;//一有不等的,就不是回文
    break;
   }
  }
  if (result){
   puts("Yes");
  }
  else puts("No");
  for (int i = V.size() - 1; i >= 0; i --){
   if (i == V.size() - 1)printf("%d", V[i]);
   else printf(" %d", V[i]);
  }
  printf("\n");
 }
 return 0;
}