1,特殊排序
- 题目描述:
-
输入一系列整数,将其中最大的数挑出,并将剩下的数进行排序。
- 输入:
- 输入第一行包括1个整数N,1<=N<=1000,代表输入数据的个数。 接下来的一行有N个整数。
- 输出:
- 可能有多组测试数据,对于每组数据, 第一行输出一个整数,代表N个整数中的最大值,并将此值从数组中去除,将剩下的数进行排序。 第二行将排序的结果输出。
- 样例输入:
-
4
1 3 4 2
- 样例输出:
-
4
1 2 3
- 提示:
-
如果数组中只有一个数,当第一行将其输出后,第二行请输出"-1"。
#include<iostream>
using namespace std;
int main(){
int n;
int arr[1001];
while(cin>>n){
int i,j;
int swap;
//如果只有一个元素
if(n==1){
cin>>swap;
cout<<swap<<endl;
cout<<"-1"<<endl;
continue;
}
//n>1时,读取元素,并且arr[0]处存放最大的元素
for(i=0;i<n;i++){
cin>>arr[i];
if(arr[i] > arr[0]){
swap = arr[i];
arr[i] = arr[0];
arr[0] = swap;
}
}
//对1~~n-1个元素进行排序
for(i = 1;i <= n-1;i++){
for(j = 1;j <= n-1-i;j++){
if(arr[j] > arr[j+1]){
swap = arr[j];
arr[j] = arr[j+1];
arr[j+1] = swap;
}
}
}
//输出
cout<<arr[0]<<endl;
for(i=1;i<n-1;i++){
cout<<arr[i]<<" ";
}
cout<<arr[n-1]<<endl;
}
return 0;
}
2,打印日期
- 题目描述:
-
给出年分m和一年中的第n天,算出第n天是几月几号。
- 输入:
-
输入包括两个整数y(1<=y<=3000),n(1<=n<=366)。
- 输出:
-
可能有多组测试数据,对于每组数据,
按 yyyy-mm-dd的格式将输入中对应的日期打印出来。
- 样例输入:
-
2000 3
2000 31
2000 40
2000 60
2000 61
2001 60
- 样例输出:
-
2000-01-03
2000-01-31
2000-02-09
2000-02-29
2000-03-01
2001-03-01
#include <stdio.h>
void showFormatdate(int year, int dates)
{
int sum, i, m, d;
int month[12] = {31,28,31,30,31,30,31,31,30,31,30,31};
if((year % 100 == 0) && (year % 400 == 0) || (year % 4 == 0) && (year % 100 != 0))
{
//润年
month[1] = 29;
}
for(i = 0, sum = 0; i < 12; i ++)
{
if(sum < dates)
{
sum += month[i];
}else
{
break;
}
}
//获取月份
m = i;
//获取当月的天数
d = month[i - 1] - (sum - dates);
//格式化输出
printf("%04d-%02d-%02d\n",year, m, d);
}
void main()
{
int year, dates;
while(scanf("%d %d", &year, &dates) != EOF)
{
showFormatdate(year, dates);
}
}
3,最小年龄的3个职工
- 题目描述:
-
职工有职工号,姓名,年龄.输入n个职工的信息,找出3个年龄最小的职工打印出来。
- 输入:
-
输入第一行包括1个整数N,1<=N<=30,代表输入数据的个数。
接下来的N行有N个职工的信息:
包括职工号(整数), 姓名(字符串,长度不超过10), 年龄(1<=age<=100)。
- 输出:
-
可能有多组测试数据,对于每组数据,
输出结果行数为N和3的较小值,分别为年龄最小的职工的信息。关键字顺序:年龄>工号>姓名,从小到大。
- 样例输入:
-
5
501 Jack 6
102 Nathon 100
599 Lily 79
923 Lucy 15
814 Mickle 65
- 样例输出:
-
501 Jack 6
923 Lucy 15
814 Mickle 65
#include <iostream>
#include <vector>
#include <string>
#include <algorithm>
using namespace std;
struct staff{
int id;
string name;
int age;
};
bool comp(staff a,staff b){
if(a.age!=b.age){
return a.age<b.age;
}
else if(a.id!=b.id){
return a.id<b.id;
}
else{
return a.name<b.name;
}
}
int main(){
//freopen("input.txt","r",stdin);
vector<staff> v;
staff *p;
int n;
while(cin>>n){
v.resize(0);
while(n--){
p = new staff;
cin>>p->id>>p->name>>p->age;
v.push_back(*p);
}
sort(v.begin(),v.end(),comp);
for(int i=0;i<3&&i<v.size();i++){
cout<<v[i].id<<" "<<v[i].name<<" "<<v[i].age<<endl;
}
}
return 0;
}