http://acm.hdu.edu.cn/showproblem.php?pid=1263
水果
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)Total Submission(s): 2754 Accepted Submission(s): 1040
Problem Description 夏天来了~~好开心啊,呵呵,好多好多水果~~
Joe经营着一个不大的水果店.他认为生存之道就是经营最受顾客欢迎的水果.现在他想要一份水果销售情况的明细表,这样Joe就可以很容易掌握所有水果的销售情况了. Input 第一行正整数N(0<N<=10)表示有N组测试数据.
每组测试数据的第一行是一个整数M(0<M<=100),表示工有M次成功的交易.其后有M行数据,每行表示一次交易,由水果名称(小写字母组成,长度不超过80),水果产地(小写字母组成,长度不超过80)和交易的水果数目(正整数,不超过100)组成. Output 对于每一组测试数据,请你输出一份排版格式正确(请分析样本输出)的水果销售情况明细表.这份明细表包括所有水果的产地,名称和销售数目的信息.水果先按产地分类,产地按字母顺序排列;同一产地的水果按照名称排序,名称按字母顺序排序.
两组测试数据之间有一个空行.最后一组测试数据之后没有空行. Sample Input
1
5
apple shandong 3
pineapple guangdong 1
sugarcane guangdong 1
pineapple guangdong 3
pineapple guangdong 1
Sample Output
guangdong
|----pineapple(5)
|----sugarcane(1)
shandong
|----apple(3)
Source
浙江工业大学第四届大学生程序设计竞赛
Recommend
JGShining | We have carefully selected several similar problems for you: 1262 1265 1261 1257 1264
思路:这道题的思路很容易,一个结构体排序,但是排好序之后的格式化输出是一个麻烦点。看了一下别人的代码,有在头尾增加两个结点,然后格式化输出,
也有用map的,我有一种预想,应该是不需要增加空间负担,而且也应该不需要使用map这种复杂的数据结构,一个线性表应该就可以解决这个问题。
折腾了一个下午,想了下面的办法,如果网友有何提议,希望能告知一二,谢谢。
#include<iostream>
#include<string>
#include<algorithm>
using namespace std;
struct node
{
string place;
string fruit;
int nCount;
};
node Node[105];
int n,nCount;
void Format() //格式化输出
{
string place = Node[0].place, fruit = Node[0].fruit;
nCount = 0;
bool isFirstTime = true;
int i;
for(i=0; i<n; ++i)
{
//如果前两项相等,累加nCount;
if ( place == Node[i].place && fruit == Node[i].fruit )
{
nCount += Node[i].nCount;
}
else //place != Node[i].place || fruit != Node[i].fruit,如果不等,则输出
{
if( isFirstTime )
{
cout << place << endl;
isFirstTime = false;
}
if( place != Node[i].place )
isFirstTime = true;
cout<<" |----" << fruit << "(" << nCount<<")" << endl;
nCount = Node[i].nCount;
fruit = Node[i].fruit;
place = Node[i].place;
}
}
if( isFirstTime )
cout<<place<<endl;
cout<<" |----" << fruit << "(" << nCount<<")" << endl;
}
bool comp(const node& N1,const node& N2)
{
if ( N1.place != N2.place)
return N1.place < N2.place;
return N1.fruit < N2.fruit;
}
int main()
{
int T,i;
cin>>T;
while(T--)
{
cin>>n;
for(i=0; i<n; ++i)
{
cin>>Node[i].fruit>>Node[i].place>>Node[i].nCount;
}
sort(Node,Node+n,comp);
Format();//格式化输出是重点
if( T )
cout<<endl;
}
return 0;
}