poj 2398 Toy Storage(计算几何)

时间:2021-08-21 11:32:36
Toy Storage
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 3315   Accepted: 1902

Description

Mom and dad have a problem: their child, Reza, never puts his toys away when he is finished playing with them. They gave Reza a rectangular box to put his toys in. Unfortunately, Reza is rebellious and obeys his parents by simply throwing his toys into the box. All the toys get mixed up, and it is impossible for Reza to find his favorite toys anymore.
Reza's parents came up with the following idea. They put cardboard partitions into the box. Even if Reza keeps throwing his toys into the box, at least toys that get thrown into different partitions stay separate. The box looks like this from the top:
poj 2398 Toy Storage(计算几何)

We want for each positive integer t, such that there exists a partition with t toys, determine how many partitions have t, toys.

Input

The input consists of a number of cases. The first line consists of six integers n, m, x1, y1, x2, y2. The number of cardboards to form the partitions is n (0 < n <= 1000) and the number of toys is given in m (0 < m <= 1000). The coordinates of the upper-left corner and the lower-right corner of the box are (x1, y1) and (x2, y2), respectively. The following n lines each consists of two integers Ui Li, indicating that the ends of the ith cardboard is at the coordinates (Ui, y1) and (Li, y2). You may assume that the cardboards do not intersect with each other. The next m lines each consists of two integers Xi Yi specifying where the ith toy has landed in the box. You may assume that no toy will land on a cardboard.

A line consisting of a single 0 terminates the input.

Output

For each box, first provide a header stating "Box" on a line of its own. After that, there will be one line of output per count (t > 0) of toys in a partition. The value t will be followed by a colon and a space, followed the number of partitions containing t toys. Output will be sorted in ascending order of t for each box.

Sample Input

4 10 0 10 100 0
20 20
80 80
60 60
40 40
5 10
15 10
95 10
25 10
65 10
75 10
35 10
45 10
55 10
85 10
5 6 0 10 60 0
4 3
15 30
3 1
6 8
10 10
2 1
2 8
1 5
5 5
40 10
7 9
0

Sample Output

Box
2: 5
Box
1: 4
2: 1

Source


题意:给定一个矩形范围,有m个隔板分开他们(保证不相交),放n个点进去(保证在矩形内且不落在线段上),问有t个球的空间有多少个,按t的升序输出
题解:用叉积二分判断每个点在哪一个空间内,记录下来就可以了

#include<stdio.h>
#include<string.h>
#include<stdlib.h>
struct point{
    double x,y;
}p[1005],sta,fin;
struct line{
    struct point a,b;
}l[1005];
int n,m,res[1005];
int cmp(const void *a,const void *b)
{
    struct line c=*(struct line *)a;
    struct line d=*(struct line *)b;
    return c.a.x>d.a.x?1:-1;
}
int mult(struct point temp,struct line temp2)
{
    if((temp2.b.x-temp.x)*(temp2.a.y-temp.y)-(temp2.b.y-temp.y)*(temp2.a.x-temp.x)>0)
        return 1;
    else return 0;
}
int mysearch(struct point temp)
{
    int low=0,high=m,mid;

    while(low<high)
    {
        mid=(low+high)>>1;
        if(mult(temp,l[mid])) high=mid;
        else low=mid+1;
    }

    return low;
}
int main()
{
    int i,j,limit,temp,cou;

    //freopen("t.txt","r",stdin);
    while(scanf("%d",&m),m)
    {
        scanf("%d%lf%lf%lf%lf",&n,&sta.x,&sta.y,&fin.x,&fin.y);
        for(i=0;i<m;i++)
        {
            scanf("%lf%lf",&l[i].a.x,&l[i].b.x);
            l[i].a.y=sta.y;  l[i].b.y=fin.y;
            res[i]=0;
        }
        for(i=0;i<n;i++) scanf("%lf%lf",&p[i].x,&p[i].y);
        qsort(l,m,sizeof(l[0]),cmp);
        l[m].a.x=fin.x;  l[m].a.y=sta.y;
        l[m].b.x=fin.x;  l[m].b.y=fin.y;
        memset(res,0,sizeof(res));
        for(limit=i=0;i<n;i++)
        {
            temp=mysearch(p[i]);
            res[temp]++;
            if(limit<res[temp]) limit=res[temp];
        }
        printf("Box\n");
        for(i=1;i<=limit;i++)
        {
            cou=0;
            for(j=0;j<=m;j++) if(res[j]==i) cou++;
            if(cou>0) printf("%d: %d\n",i,cou);
        }
    }

    return 0;
}