二叉树层序遍历的c++写法

时间:2021-02-17 11:23:12
void LevelOrder(struct node *root)//运用队列(注意头文件引用)
{
    queue<struct node*>q;
    struct node *p = root;
    if(p)
    {
        q.push(p);
    }
    while(!q.empty())
    {
        p = q.front();
        cout<<p->data;
        q.pop();
        if(p->lchild)
        {
            q.push(p->lchild);
        }
        if(p->rchild)
        {
            q.push(p->rchild);
        }
    }

}

例题选自PTA

5-10 树的遍历   (25分)

给定一棵二叉树的后序遍历和中序遍历,请你输出其层序遍历的序列。这里假设键值都是互不相等的正整数。

输入格式:

输入第一行给出一个正整数NNN≤30\le 3030),是二叉树中结点的个数。第二行给出其后序遍历序列。第三行给出其中序遍历序列。数字间以空格分隔。

输出格式:

在一行中输出该树的层序遍历的序列。数字间以1个空格分隔,行首尾不得有多余空格。

输入样例:

7
2 3 1 5 7 6 4
1 2 3 4 5 6 7

输出样例:

4 1 6 3 5 7 2
  • 时间限制:400ms
  • 内存限制:64MB
  • 代码长度限制:16kB

code:

#include<stdio.h>
#include<stdlib.h>
#include<iostream>
#include<queue>
using namespace std;
int c[40];
int ant;
struct node
{
    int data;
    struct node *lchild, *rchild;
};
struct node *rebuild(int a[], int b[], int n)
{
    struct node *root;
    int i;
    if(n==0) return NULL;
    root = (struct node*)malloc(sizeof(struct node));
    root->data = b[n-1];
    for(i = 0; i<n; i++)
    {
        if(a[i] == b[n-1]) break;
    }
    root->lchild = rebuild(a,b, i);
    root->rchild = rebuild(a+i+1, b+i, n-i-1);
    return root;
}
void LevelOrder(struct node *root)
{
    queue<struct node*>q;
    struct node *p = root;
    if(p)
    {
        q.push(p);
    }
    while(!q.empty())
    {
        p = q.front();
        c[ant++] = p->data;
        q.pop();
        if(p->lchild)
        {
            q.push(p->lchild);
        }
        if(p->rchild)
        {
            q.push(p->rchild);
        }
    }
}
int main()
{
    int n, i;
    ant = 0;
    int a[40], b[40];
    struct node *root;
    scanf("%d", &n);
    for(i = 0;i<n;i++)
    {
        scanf("%d", &a[i]);
    }
    for(i = 0;i<n;i++)
    {
        scanf("%d", &b[i]);
    }
    root = rebuild(b, a, n);
    LevelOrder(root);
    for(i = 0;i<ant;i++)
    {
        if(i==ant-1) printf("%d\n", c[i]);
        else printf("%d ", c[i]);
    }
}