ZOJ 3860: - Find the Spy

时间:2024-01-20 12:56:21
3860 - Find the Spy

Time Limit:2000MS     Memory Limit:65536KB     64bit IO Format:%lld
& %llu

Description

Whoooa! There is a spy in Marjar University. All we know is that the spy has a special ID card. Please find him out!

Input

There are multiple test cases. The first line of input contains an integer T indicating the number of test cases. For each test case:

The first line contains a integer N (3 <= N <= 100), which describes that there are N students need to be checked.

The second line contains N integers indicating the ID card number of N students. All ID card numbers are 32-bit integers.

Output

For each test case, output the ID card number which is different from others.

Sample Input

3
10
1 1 1 1 1 1 1 1 6 1
3
9 9 8
5
90016 90016 90016 2009 90016

Sample Output

6
8
2009

题意:找出N个数中与其他数不同的一个……

#include <iostream>
#include <cmath>
#include <stdio.h>
#include <string>
#include <cstring>
#include <map>
#include <set>
#include <vector>
#include <stack>
#include <queue>
#include <iomanip>
#include <algorithm>
#include <memory.h>
using namespace std;
int main()
{
    int N;
    cin>>N;
    while(N--)
    {
        int n;
        int a=-1,b=-1;
        int a1=0,b1=0;
        cin>>n;
        for(int i=0;i<n;i++)
        {
            int k;
            cin>>k;
            if(a==k||a==-1)a=k,a1++;
            else b=k,b1++;
        }
        printf("%d\n",a1>b1?b:a);
    }
    return 0;
}