- 题目描述:
-
输入字符串s和字符c,要求去掉s中所有的c字符,并输出结果。
- 输入:
-
测试数据有多组,每组输入字符串s和字符c。
- 输出:
-
对于每组输入,输出去除c字符后的结果。
- 样例输入:
-
heallo
a
- 样例输出:
-
hello
-
答疑:
解题遇到问题?分享解题心得?讨论本题请访问:http://t.jobdu.com/thread-7773-1-1.html
import java.util.*;
public class Main {
public static void test(String str, char c) {
for (int i = 0; i < str.length(); i++) {
if (str.charAt(i) != c) {
System.out.print(str.charAt(i));
} else
continue;
}
}
public static void main(String args[]) {
Scanner cin = new Scanner(System.in);
String a;
String bb;
while (cin.hasNext()) {
a = cin.nextLine();
bb = cin.nextLine();
char b = bb.charAt(0);
test(a, b);
System.out.print("\n");
}
}
}
/**************************************************************
Problem: 1049
User: vhreal
Language: Java
Result: Accepted
Time:80 ms
Memory:15416 kb
****************************************************************/