Time Limit: 1000MS | Memory Limit: 65536K | |
Total Submissions: 22537 | Accepted: 8989 |
Description
The French author Georges Perec (1936–1982) once wrote a book, La disparition, without the letter 'e'. He was a member of the Oulipo group. A quote from the book:
Tout avait Pair normal, mais tout s’affirmait faux. Tout avait Fair normal, d’abord, puis surgissait l’inhumain, l’affolant. Il aurait voulu savoir où s’articulait l’association qui l’unissait au roman : stir son tapis, assaillant à tout instant son imagination, l’intuition d’un tabou, la vision d’un mal obscur, d’un quoi vacant, d’un non-dit : la vision, l’avision d’un oubli commandant tout, où s’abolissait la raison : tout avait l’air normal mais…
Perec would probably have scored high (or rather, low) in the following contest. People are asked to write a perhaps even meaningful text on some subject with as few occurrences of a given “word” as possible. Our task is to provide the jury with a program that counts these occurrences, in order to obtain a ranking of the competitors. These competitors often write very long texts with nonsense meaning; a sequence of 500,000 consecutive 'T's is not unusual. And they never use spaces.
So we want to quickly find out how often a word, i.e., a given string, occurs in a text. More formally: given the alphabet {'A', 'B', 'C', …, 'Z'} and two finite strings over that alphabet, a word W and a text T, count the number of occurrences of W in T. All the consecutive characters of W must exactly match consecutive characters of T. Occurrences may overlap.
Input
The first line of the input file contains a single number: the number of test cases to follow. Each test case has the following format:
- One line with the word W, a string over {'A', 'B', 'C', …, 'Z'}, with 1 ≤ |W| ≤ 10,000 (here |W| denotes the length of the string W).
- One line with the text T, a string over {'A', 'B', 'C', …, 'Z'}, with |W| ≤ |T| ≤ 1,000,000.
Output
For every test case in the input file, the output should contain a single number, on a single line: the number of occurrences of the word W in the text T.
Sample Input
3
BAPC
BAPC
AZA
AZAZAZA
VERDI
AVERDXIVYERDIAN
Sample Output
1
3
0
Source
BAPC 2006 Qualification#include <stdio.h>
void getnext(char *ch, int next[]);
int kmp(char *ch1, char *ch2, int next[]);
char ch1[10010], ch2[1000010];
int next[10010];
int main()
{
int t;
scanf("%d", &t);
while(t--)
{
scanf("%s", ch1);
getnext(ch1, next);//获得next数组。
scanf("%s", ch2);
printf("%d\n", kmp(ch1, ch2, next));
}
return 0;
}
void getnext(char *ch, int next[])//对匹配串进行kmp匹配获得next数组值
{
int i, j;
i=0;
j=-1;
next[0] = -1;//初始化,next[0] = -1;
while(ch[i])
{
if(j==-1 || ch[i]==ch[j])//匹配成功时,当前ch[i]对应的next值 变为 匹配成功的ch[j]的下标值。
{
i++;
j++;
next[i] = j;
}
else
j = next[j];//匹配失败则向左移动匹配串,重新寻找,即从next[j]对应的ch[next[j]]开始。
}
}
int kmp(char *ch1, char *ch2, int next[])
{
int i, j, count=0;
i=0;
j=0;
while(ch2[i])
{
if(j==-1 || ch2[i]==ch1[j])//与上方原理基本相同
{
i++;
j++;
if(ch1[j]==0)//当匹配成功时
{
count++;//计数的加1
j = next[j];//下一个匹配位置,不需要从匹配串的开始进行,只需从其对应的next数组里的值开始就行。
}
}
else
j = next[j];
}
return count;
}