POJ 2923 Relocation(01背包变形, 状态压缩DP)

时间:2023-01-01 21:52:22

Q: 如何判断几件物品能否被 2 辆车一次拉走?

A: DP 问题. 先 dp 求解第一辆车能够装下的最大的重量, 然后计算剩下的重量之和是否小于第二辆车的 capacity, 若小于, 这 OK.

Description

Emma and Eric are moving to their new house they bought after returning from their honeymoon. Fortunately, they have a few friends helping them relocate. To move the furniture, they only have two compact cars, which complicates everything a bit. Since the furniture does not fit into the cars, Eric wants to put them on top of the cars. However, both cars only support a certain weight on their roof, so they will have to do several trips to transport everything. The schedule for the move is planed like this:

  1. At their old place, they will put furniture on both cars.
  2. Then, they will drive to their new place with the two cars and carry the furniture upstairs.
  3. Finally, everybody will return to their old place and the process continues until everything is moved to the new place.

Note, that the group is always staying together so that they can have more fun and nobody feels lonely. Since the distance between the houses is quite large, Eric wants to make as few trips as possible.

Given the weights wi of each individual piece of furniture and the capacities C1 and C2 of the two cars, how many trips to the new house does the party have to make to move all the furniture? If a car has capacity C, the sum of the weights of all the furniture it loads for one trip can be at most C.

Input

The first line contains the number of scenarios. Each scenario consists of one line containing three numbers nC1 and C2C1 and C2 are the capacities of the cars (1 ≤ Ci ≤ 100) and n is the number of pieces of furniture (1 ≤ n ≤ 10). The following line will contain n integers w1, …, wn, the weights of the furniture (1 ≤ wi ≤ 100). It is guaranteed that each piece of furniture can be loaded by at least one of the two cars.

Output

The output for every scenario begins with a line containing “Scenario #i:”, where i is the number of the scenario starting at 1. Then print a single line with the number of trips to the new house they have to make to move all the furniture. Terminate each scenario with a blank line.

Sample Input

2
6 12 13
3 9 13 3 10 11
7 1 100
1 2 33 50 50 67 98

Sample Output

Scenario #1:
2 Scenario #2:
3

思路:

  1. 题目给出, 一共 10 件家具, 所以可以使用状态压缩描述家具被装走的情况
  2. 检查所有的状态(共 1<<n), 并判断其能够被 2 辆车一次带走, 可以的状态存储到 state 数组
  3. 对 state 数组进行01 背包, 状态转移方程为 dp[s|state] = min(dp[s|state], dp[state]+1), 显然是个 push 的过程

总结:

  1. 状态比较少时, 应该形成考虑状态压缩的思维定式, 就像 n<15 时可以暴力破解一样
  2. 状态转移方程有 push 和 pull 两种, push 是指根据当前状态s来更新另一个状态 news; pull 是指通过另一个状态来更新当前状态
  3. 在思路(3)的状态转移方程中可以看出, 当前状态是 state, 另一个状态是 s|state, 所以是 push
  4. 处理状态压缩问题时, 读入的数组从 0 开始比较好, 因为 1<<I, I 总是从0 开始的
  5. 代码第 48 行, 没判断 j &(state[i]) 导致 TLE 一次

代码:

#include <iostream>
using namespace std; const int INF = 0X3F3F3F3F;
const int MAXN = 10 + 1<<11;
int N, C1, C2;
int a[15];
bool dp[MAXN];
int dp2[MAXN];
int state[MAXN]; bool check(const int &s) {
memset(dp, 0, sizeof(dp));
dp[0] = true;
int sum = 0;
for(int i = 0; i < N; i ++) {
if(s & (1<<i)) { // 第 i 位为 1
sum += a[i];
for(int j = C1; j >= a[i]; j--) { // 背包的容量是 C1, 01背包逆序遍历
if(dp[j-a[i]])
dp[j] = true;
}
}
}
for(int i = 0; i <= sum; i++) { // 本来写成 C1
if(dp[i] && sum-i <= C2) {
return true;
}
}
return false;
} int solve_dp() {
memset(state, 0, sizeof(state));
int len = 0;
int inf = 1<<N;
for(int i = 0; i <= inf; i ++) { // <=
if(check(i))
state[len++] = i;
} // 第二次背包
memset(dp2, 0x3f, sizeof(dp2)); // 初始化为 INF
dp2[0] = 0;
for(int i = 0; i < len; i ++) {
for(int j = inf; j >= 0; j --) {
if(!(j & (state[i]))) {
dp2[j|state[i]] = min(dp2[j|state[i]], dp2[j]+1);
}
}
}
return dp2[(1<<N)-1];
}
int main() {
freopen("E:\\Copy\\ACM\\测试用例\\in.txt", "r", stdin);
int testcase;
cin >> testcase;
int tc = 0;
while(testcase--) {
tc++;
scanf("%d%d%d", &N, &C1, &C2);
for(int i = 0; i < N; i ++) {
scanf("%d", &a[i]);
}
// solve
printf("Scenario #%d:\n%d\n\n", tc, solve_dp());
}
return 0;
}

  

update 2014年3月14日15:30:07

1. 总结 (5), 为什么不添加判断会超时? 假如不添加判断, 那么当 j&state[i] != 0 时也会执行状态转移方程. 考虑状态 state[k] 是 state[i] 的子集, 同时 j&state[k] == 0, 那么

j|state[i] == j|state[j] 同时 dp[j|state[i]] >= dp[j|state[k]], 所以对 j&state[i] != 0 的 case, 直接 continue 就好

POJ 2923 Relocation(01背包变形, 状态压缩DP)的更多相关文章

  1. POJ 2923 Relocation 装车问题 【状态压缩DP】&plus;【01背包】

    题目链接:https://vjudge.net/contest/103424#problem/I 转载于:>>>大牛博客 题目大意: 有 n 个货物,并且知道了每个货物的重量,每次用 ...

  2. POJ 2923 【01背包&plus;状态压缩&sol;状压DP】

    题目链接 Emma and Eric are moving to their new house they bought after returning from their honeymoon. F ...

  3. poj 2441 Arrange the Bulls(状态压缩dp)

    Description Farmer Johnson's Bulls love playing basketball very much. But none of them would like to ...

  4. POJ 1185 炮兵阵地 经典的 状态压缩dp

    炮兵阵地 Time Limit: 2000MS   Memory Limit: 65536K Total Submissions: 16619   Accepted: 6325 Description ...

  5. poj 2411 Mondriaan&&num;39&semi;s Dream(状态压缩dp)

    Description Squares and rectangles fascinated the famous Dutch painter Piet Mondriaan. One night, af ...

  6. POJ 2411 Mondriaan&&num;39&semi;s Dream &lbrack;经典状态压缩dp&rsqb;

    题意:略. 思路:这一题开始做的时候完全没有思路,便去看了别人的题解. 首先,对于这个题目解法想有一个初步的了解,请看这里:http://www.2cto.com/kf/201208/146894.h ...

  7. POJ 1837 Balance&lpar;01背包变形&comma; 枚举DP&rpar;

    Q: dp 数组应该怎么设置? A: dp[i][j] 表示前 i 件物品放入天平后形成平衡度为 j 的方案数 题意: 有一个天平, 天平的两侧可以挂上重物, 给定 C 个钩子和G个秤砣. 2 4 - ...

  8. POJ 2441 Arrange the Bulls(状态压缩DP&rpar;

    题意很简单,n头牛,m个位置,每头牛有各自喜欢的位置,问安排这n头牛使得每头牛都在各自喜欢的位置有几种安排方法. 2000MS代码: #include <cstdio> #include ...

  9. POJ 2836:Rectangular Covering(状态压缩DP)

    题目大意:在一个平面内有若干个点,要求用一些矩形覆盖它们,一个矩形至少覆盖两个点,可以相互重叠,求矩形最小总面积. 分析: 数据很小,很容易想到状压DP,我们把点是否被覆盖用0,1表示然后放在一起得到 ...

随机推荐

  1. 智能车学习(十一)&mdash&semi;&mdash&semi;陀螺仪学习

    一.学习说明 感觉就是配置I2C通信,然后直接移植51代码... 二.代码分享: 1.头文件: #ifndef I2C_GYRO_H_ #define I2C_GYRO_H_ /*********** ...

  2. Fix the &OpenCurlyDoubleQuote;No Private Key” Error Message

    This article will show you how to correct the “No Private Key” error message in Windows Internet Inf ...

  3. 洛谷P2735 电网 Electric Fences

    P2735 电网 Electric Fences 11通过 28提交 题目提供者该用户不存在 标签USACO 难度普及/提高- 提交  讨论  题解 最新讨论 暂时没有讨论 题目描述 在本题中,格点是 ...

  4. iOS 进阶 第四天&lpar;0329&rpar;

    0329 UIScrollView的常见属性及其解释 常见属性,如下图: 具体解释,如下图: 喜马拉雅设置的例子 代码: 效果     

  5. Javascript&colon;作用域 学习总结

    作用域(scope): 变量与函数的可访问范围,控制着变量与函数的可见性和生命周期   作用域分类: javascript中,变量的作用域分为:全局作用域,局部作用域 局部变量的优先级大于全局变量,或 ...

  6. Bootstrap 模态框(Modal)插件id冲突

    <!DOCTYPE html><html><head>    <meta charset="utf-8">     <titl ...

  7. django js引入失效问题

    今天将项目中html文件下的自定义scrept代码单独独立,结果js引入无效,没有任何时间效果,在浏览器查看引入文件也正常. 后来发现自己引入的位置不对,js的引入文件应该放在body体内,而我把他们 ...

  8. 使用session统计在线人数

    效果图如下 这里是Chrome浏览器新登录一个用户 代码展示 package com.test.Util; import java.util.ArrayList; import javax.servl ...

  9. Linux系统编程目录

    进程环境 进程控制 1. fork.vfork.clone 2. 回收子进程 3. exec函数族 进程关系 1. 进程组 2. 会话 信号 1. 函数函数sigaction.signal 2.僵尸进 ...

  10. jQuery-二级导航

    <!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/ ...