A prefix of a string is a substring starting at the beginning of the given string. The prefixes of “carbon” are: “c”, “ca”, “car”, “carb”, “carbo”, and “carbon”. Note that the empty string is not considered a prefix in this problem, but every non-empty string is considered to be a prefix of itself. In everyday language, we tend to abbreviate words by prefixes. For example, “carbohydrate” is commonly abbreviated by “carb”. In this problem, given a set of words, you will find for each word the shortest prefix that uniquely identifies the word it represents.
In the sample input below, “carbohydrate” can be abbreviated to “carboh”, but it cannot be abbreviated to “carbo” (or anything shorter) because there are other words in the list that begin with “carbo”.
An exact match will override a prefix match. For example, the prefix “car” matches the given word “car” exactly. Therefore, it is understood without ambiguity that “car” is an abbreviation for “car” , not for “carriage” or any of the other words in the list that begins with “car”.
Input
The input contains at least two, but no more than 1000 lines. Each line contains one word consisting of 1 to 20 lower case letters.
Output
The output contains the same number of lines as the input. Each line of the output contains the word from the corresponding line of the input, followed by one blank space, and the shortest prefix that uniquely (without ambiguity) identifies this word.
Sample Input
carbohydrate
cart
carburetor
caramel
caribou
carbonic
cartilage
carbon
carriage
carton
car
carbonate
Sample Output
carbohydrate carboh
cart cart
carburetor carbu
caramel cara
caribou cari
carbonic carboni
cartilage carti
carbon carbon
carriage carr
carton carto
car car
carbonate carbona
理解题意,这个前缀不一定是字符串集,而是最短的且能够唯一确定这个字符串的前缀。
eg
abcde
abc
输出 : abcde 肯定可以唯一确定,但却不是最短的,abc呢?够短,但是却不是唯一确定的,它既是abc的前缀,同时也是abcde的前缀。所以就是abcd。
看代码
#include <iostream>
#include<algorithm>
#include<string.h>
#include<stdio.h>
#include<math.h>
#include<stack>
#define LL long long
using namespace std;
const int MAXN= 1000000+10;
const int inf =0x3f3f3f3f;
/*--------------------------*/
int ch[MAXN][40];
int val[MAXN];
int word[MAXN];
int sz;
char str[1000+5][30];
char tmp[100];
void init(){
memset(ch[0],0,sizeof(ch[0]));
memset(val,0,sizeof(val));
sz=1;
}
int idx(char c){return c-'a';}
void Insert(char *s){
int i,j,len=strlen(s);
int u=0;
for(i=0;i<len;i++){
int c=idx(s[i]);
if(!ch[u][c]){
memset(ch[sz],0,sizeof(ch[sz]));
val[sz]=0;
ch[u][c]=sz++;
}
u=ch[u][c];
word[u]++;
}
val[u]=1;
}
void Find(char *s){
int i,j,len=strlen(s);
int u=0;
for(i=0;i<len;i++){
int c=idx(s[i]);
printf("%c",s[i]);
u=ch[u][c];
if(word[u]==1) break; // 这里要理解,这样就可以表明是唯一确定的最短前缀;
}
}
int main()
{
int n=0;
init();
while(scanf("%s",tmp)!=EOF){
Insert(tmp);
strcpy(str[n++],tmp);
}
for(int i=0;i<n;i++){
printf("%s ",str[i]);
Find(str[i]);
putchar('\n');
}
return 0;
}