Think:
1打表找规律,寻找循环节
2字符串存储大数+大数取模
Parity check
Time Limit: 2000MS Memory Limit: 524288KB
Problem Description
Fascinated with the computer games, Gabriel even forgets to study. Now she needs to finish her homework, and there is an easy problem:
f(n)=
She is required to calculate f(n) mod 2 for each given n. Can you help her?
Input
Multiple test cases. Each test case is an integer n(0≤n≤) in a single line.
Output
For each test case, output the answer of f(n)mod2.
Example Input
2
Example Output
1
Hint
Author
“浪潮杯”山东省第八届ACM大学生程序设计竞赛(感谢青岛科技大学)
以下为Accepted代码
#include <bits/stdc++.h>
using namespace std;
int main()
{
char st[1004];
int sum, i;
while(scanf("%s", st) != EOF)
{
int len = strlen(st);
sum = 0;
for(i = len-1; i >= 0; i--){
sum = (sum + (st[i] - '0')) % 3;///及时取模,避免数据储存超出限制
}
if(sum == 0)
printf("0\n");
else if(sum == 1 || sum == 2)
printf("1\n");
}
return 0;
}
/***************************************************
User name:
Result: Accepted
Take time: 0ms
Take Memory: 196KB
Submit time: 2017-05-11 21:42:35
****************************************************/