1042. 字符统计(20)

时间:2022-12-20 12:23:18

题目链接

题目:

请编写程序,找出一段给定文字中出现最频繁的那个英文字母。

输入格式:

输入在一行中给出一个长度不超过1000的字符串。字符串由ASCII码表中任意可见字符及空格组成,至少包含1个英文字母,以回车结束(回车不算在内)。

输出格式:

在一行中输出出现频率最高的那个英文字母及其出现次数,其间以空格分隔。如果有并列,则输出按字母序最小的那个字母。统计时不区分大小写,输出小写字母。

输入样例:
This is a simple TEST.  There ARE numbers and other symbols 1&2&3...........
输出样例:
e 7

题解:

简单的字符串处理。

代码:

#include <cstdio>
#include <iostream>
#include <cstring>
using namespace std;

int cnt[256];
int main()
{
	char s[1010];
	cin.getline(s, 1010);
	int l = strlen(s);
	
	for(int i = 0; i < l; i++)
	{
		if(s[i] >= 'a' && s[i] <= 'z')
			cnt[s[i]]++;
		if(s[i] >= 'A' && s[i] <= 'Z')
			cnt[s[i] - 'A' + 'a']++;
	}
	
	int ans = 'a', max = -1;
	for(int i = 'a'; i <= 'z'; i++)
	{
		if(cnt[i] > max)
		{
			max = cnt[i];
			ans = i;
		}
	}
	printf("%c %d", ans, max);
	
	return 0;
}