1042. 字符统计(20)
时间限制400 ms内存限制65536 kB
代码长度限制8000 B
判题程序Standard作者CHEN, Yue
请编写程序,找出一段给定文字中出现最频繁的那个英文字母。
输入格式:
输入在一行中给出一个长度不超过1000的字符串。字符串由ASCII码表中任意可见字符及空格组成,至少包含1个英文字母,以回车结束(回车不算在内)。
输出格式:
在一行中输出出现频率最高的那个英文字母及其出现次数,其间以空格分隔。如果有并列,则输出按字母序最小的那个字母。统计时不区分大小写,输出小写字母。
输入样例:This is a simple TEST. There ARE numbers and other symbols 1&2&3...........输出样例:
e 7
#include <cstdio>
#include <iostream>
#include <map>
#include <cctype>
using namespace std;
int main(){
string s;
getline(cin,s);
map <char ,int> zimu;
int len=s.size();
for(int i=0;i<len;i++){
if(s[i]>='A'&&s[i]<='Z'||s[i]>='a'&&s[i]<='z'){
char c=tolower(s[i]);
if(!zimu.count(c)){
zimu.insert(pair<char,int>(c,1));
}else{
zimu[c]++;
}
}
}
char ans;
int max=0;
map<char,int> ::iterator iter;
for(iter=zimu.begin();iter!=zimu.end();iter++){
if(iter->second>max){
max=iter->second;
ans=iter->first;
}else if(iter->second==max){
if(iter->first<ans){
ans=iter->first;
}
}
}
printf("%c %d",ans,max);
return 0;
}