1042. 字符统计(20)
原题链接
请编写程序,找出一段给定文字中出现最频繁的那个英文字母。
输入格式:
输入在一行中给出一个长度不超过1000的字符串。字符串由ASCII码表中任意可见字符及空格组成,至少包含1个英文字母,以回车结束(回车不算在内)。
输出格式:
在一行中输出出现频率最高的那个英文字母及其出现次数,其间以空格分隔。如果有并列,则输出按字母序最小的那个字母。统计时不区分大小写,输出小写字母。
输入样例:
This is a simple TEST. There ARE numbers and other symbols 1&2&3...........
输出样例:
e 7
注意:
- C++中getline函数的使用
- cin 遇到空格默认为输入结束
代码:
#include <iostream>
#include <cctype>
#include <string>
using namespace std;
int main()
{
string str;
getline(cin,str);
int len = str.size();
for(int i=0; i<len; i++)
str[i] = tolower(str[i]);//大写字母转换为小写字母
int HASH[26] = {0};
for(int i=0; i<len; i++){
if(str[i]>='a' && str[i]<='z'){
HASH[str[i]-'a']++;
}
}
int MAX = 0;
for(int i=1; i<26; i++){
if(HASH[i] > HASH[MAX]){
MAX = i;
}
}
char temp = MAX + 'a';
cout << temp << " " << HASH[MAX] << endl;
return 0;
}