联合权值
- Description
无向连通图
- Input Format
输入文件名为link.in。
第一行包含
接下来
最后
- Output Format
输出文件名为link.out。
输出共
- Sample Input
5
1 2
2 3
3 4
4 5
1 5 2 3 10
- Sample Output
20 74
- Hint
【样例说明】
本例输入的图如上所示,距离为2的有序点对有(1,3)、(2,4)、(3,1)、(3,5)、(4,2)、(5,3)。其联合权值分别为2、15、2、20、15、20。其中最大的是20,总和为74。
【数据说明】
对于30%的数据,
对于60%的数据,
对于100%的数据,
- 分析
每次枚举一个点,与这个点相连的点两两符合题意。处理总和是可以先统计之前所有点的和,新的点进来时只需跟这个值相乘即可,复杂度可大大降低。(详见下方古老的代码)
#include <cstdio>
#include <cstdlib>
#include <algorithm>
#include <cstring>
#include <cmath>
#include <vector>
#include <stack>
#include <queue>
#include <map>
using namespace std;
int i,j,n,x,y,tot,ans,ma,val[200002],last[200002];
struct info{
int next,to;
}e[400002];
void add(int x,int y){
e[++tot].to=y;
e[tot].next=last[x];
last[x]=tot;
}
int main(){
freopen("in.txt","r",stdin);
freopen("out.txt","w",stdout);
scanf("%d",&n);
for (i=1;i<=n-1;i++){
scanf("%d%d",&x,&y);
add(x,y);
add(y,x);
}
for (i=1;i<=n;i++) scanf("%d",&val[i]);
for (i=1;i<=n;i++) {
int s=0,max1=0,max2=0;
for (j=last[i];j;j=e[j].next) {
ans=(ans+(s*val[e[j].to]))%10007;
s=(s+val[e[j].to])%10007;
if (val[e[j].to]>max2) max2=val[e[j].to];
if (max2>max1) max2=max1,max1=val[e[j].to];
}
ma=max(ma,max1*max2);
}
printf("%d %d",ma,(ans*2)%10007);
fclose(stdin); fclose(stdout);
}