HDU 4734 F(x)(数位dp)

时间:2022-12-16 10:36:46

F(x)

Time Limit: 1000/500 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 7761    Accepted Submission(s): 3046


Problem Description
For a decimal number x with n digits (A nA n-1A n-2 ... A 2A 1), we define its weight as F(x) = A n * 2 n-1 + A n-1 * 2 n-2 + ... + A 2 * 2 + A 1 * 1. Now you are given two numbers A and B, please calculate how many numbers are there between 0 and B, inclusive, whose weight is no more than F(A).
 

Input
The first line has a number T (T <= 10000) , indicating the number of test cases.
For each test case, there are two numbers A and B (0 <= A,B < 10 9)
 

Output
For every case,you should output "Case #t: " at first, without quotes. The  t is the case number starting from 1. Then output the answer.
 

Sample Input
 
 
3 0 100 1 10 5 100
 

Sample Output
 
 
Case #1: 1 Case #2: 2 Case #3: 13

#include<bits/stdc++.h>
using namespace std;
int dp[22][200001],a,b,c[22];
int dfs(int pos,int num,int flag)
{
    if(pos==-1)return num>=0;
    if(num<0)return 0;
    if(!flag&&dp[pos][num]!=-1)
        return dp[pos][num];
    int r=flag?c[pos]:9;
    int ans=0;
    for(int i=0;i<=r;i++)
    {
        ans+=dfs(pos-1,num-i*(1<<pos),flag&&i==r);
    }
    if(!flag)
        dp[pos][num]=ans;
    return ans;
}
int F(int x)
{
    int ans=0,l=0;
    while(x)
    {
        ans=ans+(x%10)*(1<<l);
        l++;x/=10;
    }
    return ans;
}
int cal()
{
    int l=0;
    while(b)
    {
        c[l++]=b%10;
        b/=10;
    }
    return dfs(l-1,F(a),1);
}
int main()
{
    int T,cas=0;scanf("%d",&T);
    memset(dp,-1,sizeof(dp));
    while(T--)
    {
        scanf("%d%d",&a,&b);
        printf("Case #%d: %d\n",++cas,cal());
    }
    return 0;
}