Time Limit: 1000MS Memory Limit: 65536KB
Problem Description
用类成员函数完成5个整型数组元素的输入、从小到大排序、排序后数组元素的输出。
Input
输入5个数组元素。
Output
输出5个数组元素从小到大排序后的结果。(最后一个数后面既没有空格也没有换行)
Example Input
8 9 1 5 4
Example Output
1 4 5 8 9
Code realization
#include <iostream>
using namespace std;
class Number
{
int a[5];
public:
void set()
{
for(int i=0;i<5;i++)
cin>>a[i];
}
void p()
{
for(int i=0;i<4;i++)
{
int k=i;
for(int j=i+1;j<5;j++)
{
if(a[k]>a[j])
k=j;
}
if(k!=i)
{
int m;
m=a[i];
a[i]=a[k];
a[k]=m;
}
}
}
void show()
{
for(int i=0;i<5;i++)
{
cout<<a[i];
if(i<4)
cout<<" ";
}
cout<<endl;
}
}n;
int main()
{
n.set();
n.p();
n.show();
return 0;
}