Program C--二分

时间:2022-09-19 22:48:49

My birthday is coming up and traditionally I’m serving pie. Not just one pie, no, I have a number N of them, of various tastes and of various sizes. F of my

friends are coming to my party and each of them gets a piece of pie. This should be one piece of one pie, not several small pieces since that looks messy. This

piece can be one whole pie though. My friends are very annoying and if one of them gets a bigger piece than the others, they start complaining. Therefore all of

them should get equally sized (but not necessarily equally shaped) pieces, even if this leads to some pie getting spoiled (which is better than spoiling the

party). Of course, I want a piece of pie for myself too, and that piece should also be of the same size. What is the largest possible piece size all of us can get?

All the pies are cylindrical in shape and they all have the same height 1, but the radii of the pies can be different.

Input

One line with a positive integer: the number of test cases. Then for each test case: • One line with two integers N and F with 1 ≤ N, F ≤ 10000: the number

of pies and the number of friends. • One line with N integers ri with 1 ≤ ri ≤ 10000: the radii of the pies.

Output

For each test case, output one line with the largest possible volume V such that me and my friends can all get a pie piece of size V . The answer should be

given as a oating point number with an absolute error of at most 10−3.

Sample Input

3 3 3 4 3 3 1 24 5 10 5 1 4 2 3 4 5 6 5 4 2

Sample Output

25.1327 3.1416 50.2655

题目大意:我有个生日宴会邀请了f个朋友,宴会有n块饼,饼的高度都为1,分别给出n块饼的面积,要使得我和f个朋友每个人所分得的饼的体积都一样,

求每人分得的最大体积。

注意:每个人只能得到一块饼且不能由两块或两块以上不同的饼组合而成。

分析:首先用求出各个饼的体积,再将他们相加求出总体积(V),用V除以总人数(f+1)每人就可以得到最大的饼,由于每人不能由两块及两块以上不同的饼组合而成,

所以需要将V/(f+1)二分,直到找到最大且最合适的值。

代码如下:

#include <iostream>
#include <cstdio>
#include <cmath>
double pi=acos(-1);
const int maxn=10005;
double a[maxn];
int n,f;
using namespace std;
bool test(double x)
{
int num=0;
for(int i=0;i<n;i++)
{
num+=int(a[i]/x);
}
if(num>=f)
return true;
else
return false;
}
int main()
{
int t,r;
double max,v,left,right,mid;
scanf("%d",&t);
while(t--)
{ scanf("%d%d",&n,&f);
f=f+1;
for(int i=0;i<n;i++)
{
scanf("%d",&r);
a[i]=pi*r*r;
v+=a[i];
}
max=v/f;
left=0.0;
right=max;
while((right-left)>1e-6)
{
mid=(right+left)/2;
if(test(mid))
left=mid;
else
right=mid;
}
printf("%.4f\n",mid); }
}

Program C--二分的更多相关文章

  1. &lbrack;bzoj1901&rsqb;&lbrack;zoj2112&rsqb;&lbrack;Dynamic Rankings&rsqb; &lpar;整体二分&plus;树状数组 or 动态开点线段树 or 主席树&rpar;

    Dynamic Rankings Time Limit: 10 Seconds      Memory Limit: 32768 KB The Company Dynamic Rankings has ...

  2. Codeforces Round &num;379 &lpar;Div&period; 2&rpar; A B C D 水 二分 模拟

    A. Anton and Danik time limit per test 1 second memory limit per test 256 megabytes input standard i ...

  3. 【BZOJ-2527】Meteors 整体二分 &plus; 树状数组

    2527: [Poi2011]Meteors Time Limit: 60 Sec  Memory Limit: 128 MBSubmit: 831  Solved: 306[Submit][Stat ...

  4. HDU 4768 Flyer(二分)

    题目链接: 传送门 Flyer Time Limit: 1000MS     Memory Limit: 32768 K Description The new semester begins! Di ...

  5. Flyer&lpar;二分 HDU4768&rpar;

    Flyer Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others) Total Submiss ...

  6. &lbrack;ACM&rsqb; poj 1064 Cable master (二分查找)

    Cable master Time Limit: 1000MS   Memory Limit: 10000K Total Submissions: 21071   Accepted: 4542 Des ...

  7. &lbrack;ACM&lowbar;图论&rsqb; Sorting Slides&lpar;挑选幻灯片,二分匹配,中等)

    Description Professor Clumsey is going to give an important talk this afternoon. Unfortunately, he i ...

  8. &lbrack;ACM&lowbar;图论&rsqb; The Perfect Stall 完美的牛栏(匈牙利算法、最大二分匹配)

    描述 农夫约翰上个星期刚刚建好了他的新牛棚,他使用了最新的挤奶技术.不幸的是,由于工程问题,每个牛栏都不一样.第一个星期,农夫约翰随便地让奶牛们进入牛栏,但是问题很快地显露出来:每头奶牛都只愿意在她们 ...

  9. POj3104 Drying&lpar;二分&rpar;

    Drying Time Limit: 2000MS Memory Limit: 65536K Description It is very hard to wash and especially to ...

  10. POJ 3903:Stock Exchange(裸LIS &plus; 二分优化)

    http://poj.org/problem?id=3903 Stock Exchange Time Limit: 1000MS   Memory Limit: 65536K Total Submis ...

随机推荐

  1. Sharepoint学习笔记—习题系列--70-573习题解析 -&lpar;Q94-Q96&rpar;

    Question 94You need to create a custom application that provides users with the ability to create a ...

  2. Codeforces Gym 100203G G - Good elements 暴力

    G - Good elementsTime Limit: 20 Sec Memory Limit: 256 MB 题目连接 http://acm.hust.edu.cn/vjudge/contest/ ...

  3. 给postfix设置黑名单

    国内私募机构九鼎控股打造APP,来就送 20元现金领取地址:http://jdb.jiudingcapital.com/phone.html内部邀请码:C8E245J (不写邀请码,没有现金送)国内私 ...

  4. &lbrack;转&rsqb; react-native 之布局篇

    PS: 苹果使用的宽度单位是为了设计开发者在应用上使用接近的数值.比如宽度范围都在320-414之间.但是宽度对应到像素是有一个转换比例的,对于背景图尤其要准备足够像素的图片.这个足够像素可以通过公式 ...

  5. javascript、js操作json方法总结&lpar;json字符创转换json对象&rpar;

    相信前端的同学们对json并不陌生,接触过很多.但是很少人知道json的全称是什么,哈哈,我也是查资 料知道的.(JSON JavaScript Object Notation是一种轻量级的数据交换格 ...

  6. 局域网架个YUM源-HTTP的

    在安装CDH时,这是个绕不过去的坎. 参考URL: http://www.21ops.com/linux/26465.html 奇怪的是,我并没执行creatrepo这个,直接将光盘MOUNT来用的. ...

  7. freemarker自己定义标签(二)

    freemarker自己定义标签 1.自己定义标签 通过自己定义标签,写一个反复指定字符串 2.实现源代码 <html> <head> <meta http-equiv= ...

  8. 推荐一款基于bootstrap的漂亮的前端模板—inspinia&lowbar;admin

    首先给出Demo网址:http://cn.inspinia.cn inspinia admin 最新版 bootstrap 完全响应式后台管理模板,采用扁平化设计.使用Bootstrap 3+ Fra ...

  9. BeanFactory的实现原理

    先来看看Java代码获取Spring中Bean的代码(一共有五种方式,这里只展示其中一种方法): 有没有发现上面的代码与利用反射实现工厂模式的代码很相似.对,你没有看错,Spring中的BeanFac ...

  10. jenkins发版脚本更新

    jenkins 项目名中明确了 是jar tar.gz war包研发需要提供  项目名-地点-环境(研发.测试.生产)-应用项目名称(admin)-包格式(jar\war\gz) deployment ...