1065. A+B and C (64bit) (20)

时间:2022-03-30 19:50:18

Given three integers A, B and C in [-263, 263], you are supposed to tell whether A+B > C.

Input Specification:

The first line of the input gives the positive number of test cases, T (<=10). Then T test cases follow, each consists of a single line containing three integers A, B and C, separated by single spaces.

Output Specification:

For each test case, output in one line "Case #X: true" if A+B>C, or "Case #X: false" otherwise, where X is the case number (starting from 1).

Sample Input:
3
1 2 3
2 3 4
9223372036854775807 -9223372036854775808 0
Sample Output:
Case #1: false
Case #2: true
Case #3: false
--------------华丽的分割线-----------------
分析:要注意的就是可能会溢出,所以若A > 0,B > 0,A+B<=0,则正溢出;若A<0,B<0,A+B>=0,则负溢出
代码:
#include<cstdio>
#include<cstdlib>

int main(void)
{
	long long A,B,C;
	int N;
	scanf("%d",&N);
	for(int i=1;i<=N;++i)
	{
		scanf("%lld %lld %lld",&A,&B,&C);
		printf("Case #%d: ",i);
		long long add = A + B;
		if(A>0 && B>0 && add <= 0)
		{
			printf("true\n");
			continue;
		}
		if(A<0 && B < 0 && add >= 0)
		{
			printf("false\n");
			continue;
		}
		if(add>C)
				printf("true\n");
		else
				printf("false\n");
	}

	system("pause");
	return 0;
}