Problem Description
If we sum up every digit of a number and the result can be exactly divided by 10, we say this number is a good number.
You are required to count the number of good numbers in the range from A to B, inclusive.
You are required to count the number of good numbers in the range from A to B, inclusive.
Input
The first line has a number T (T <= 10000) , indicating the number of test cases.
Each test case comes with a single line with two numbers A and B (0 <= A <= B <= 1018).
Each test case comes with a single line with two numbers A and B (0 <= A <= B <= 1018).
Output
For test case X, output "Case #X: " first, then output the number of good numbers in a single line.
Sample Input
2
1 10
1 20
1 10
1 20
Sample Output
Case #1: 0 Case #2: 1
Hint
The answer maybe very large, we recommend you to use long long instead of int.
#include<cstdio> __int64 sum(__int64 b)
{
int flag=;
__int64 s=b,sb;
__int64 sum=;
while(s!=)
{
sum+=s%;
s/=;
}
sum=sum-b%;
sum%=;
if(sum== || sum+b%>=) flag=;
else flag=;
sb=b/-flag;
return sb;
} int main()
{
__int64 a,b;
int t,step=,k;
scanf("%d",&t);
while(t--)
{
k=;
scanf("%I64d%I64d",&a,&b);
if(a==) k=;
printf("Case #%d: %I64d\n",step++,sum(b)-sum(a-)+k);
}
return ;
}
数论,找规律