A/B(扩展欧几里德)

时间:2021-08-23 22:03:26

A/B

Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 3340    Accepted Submission(s): 2534

Problem Description
要求(A/B)%9973,但由于A很大,我们只给出n(n=A%9973)(我们给定的A必能被B整除,且gcd(B,9973) = 1)。
Input
数据的第一行是一个T,表示有T组数据。
每组数据有两个数n(0 <= n < 9973)和B(1 <= B <= 10^9)。
Output
对应每组数据输出(A/B)%9973。
Sample Input
2
1000 53
87 123456789
Sample Output
7922
6060
Author
xhd
题解:我列的等式是B*x-9973*y=n;
带入-9973竟然不对。。。还想着x%9973还可能为负数呐,看来自己连取模定义都不知道。。。。x%9973=(x+9973)%9973;x不能为负。。。。话不多说,代码贴上;
代码:
 #include<iostream>
#include<algorithm>
#include<cstdio>
#include<cstring>
#include<cmath>
#include<vector>
#define mem(x,y) memset(x,y,sizeof(x))
using namespace std;
typedef long long LL;
const int INF=0x3f3f3f3f;
LL e_gcd(LL a,LL b,LL &x,LL &y){
if(!b){
x=;y=;
return a;
}
else{
LL d=e_gcd(b,a%b,x,y);
LL temp=x;
x=y;
y=temp-a/b*y;
return d;
}
}
LL cal(LL a,LL b,LL c){
LL x,y,gcd;
gcd=e_gcd(a,b,x,y);
x*=(c/gcd);
if(b<)b=-b;
b/=gcd;
x=x%b;
if(x<=)x+=b;
return x%;
}
int main(){
LL T,n,b;
scanf("%lld",&T);
while(T--){
scanf("%lld%lld",&n,&b);
printf("%lld\n",cal(b,,n));
}
return ;
}