【C++ 字符串】替换字符串中的字符

时间:2025-03-15 07:17:10

仅供本人学习记录
Description
Write a program to input several strings from the keyboard and replace each space in these string with the character ‘@’

Input
输入有多行,第一行输入一个整数N,后面N行每行输入一个字符串,以‘#’为定界符表示字符串结束

Output
输出有N行,每行输出一个替换字符后的字符串

Sample Input
3
A cat#
a b c#
a #
Sample Output
A@cat
a@b@c
a@@@
HINT
注意:输入N后和每个字符串后的回车符的处理

//代码

#include<iostream>//使用@替换空格
#include<string>
using namespace std;
int main()
{
	int a,b=0;
	string str1,str2="@";
	cin>>a;
	while(a--)
	{
		getline(cin,str1,'#');
		while((b=(" "))!=-1)
			{
				(b,1,str2,0,1);
			}
		cout<<str1<<endl;
	}
}