Best Cow Line(POJ3617)Java实现

时间:2025-03-09 12:42:35

Description

FJ is about to take his N (1 ≤ N ≤ 2,000) cows to the annual"Farmer of the Year" competition. In this contest every farmer arranges his cows in a line and herds them past the judges.

The contest organizers adopted a new registration scheme this year: simply register the initial letter of every cow in the order they will appear (., If FJ takes Bessie, Sylvia, and Dora in that order he just registers BSD). After the registration phase ends, every group is judged in increasing lexicographic order according to the string of the initials of the cows’ names.

FJ is very busy this year and has to hurry back to his farm, so he wants to be judged as early as possible. He decides to rearrange his cows, who have already lined up, before registering them.

FJ marks a location for a new line of the competing cows. He then proceeds to marshal the cows from the old line to the new one by repeatedly sending either the first or last cow in the (remainder of the) original line to the end of the new line. When he’s finished, FJ takes his cows for registration in this new order.

Given the initial order of his cows, determine the least lexicographic string of initials he can make this way.

Input

  • Line 1: A single integer: N
  • Lines 2…N+1: Line i+1 contains a single initial (‘A’…‘Z’) of the cow in the ith position in the original line

Output

The least lexicographic string he can make. Every line (except perhaps the last one) contains the initials of 80 cows (‘A’…‘Z’) in the new line.

Sample Input

6
A
C
D
B
C
B
Sample Output

ABCBCD

分析:
按字典序比较S和S翻转后的字符串S`

  • 如果S 较小,则从S1的开头取出一个文字加到T的末尾
  • 如果S1较小,则从S1的末尾取出一个文字加到T的末尾

代码:

import java.util.*;

public class Main{
	
	public static void main(String[] args) {
		Scanner sc = new Scanner(System.in);
		int n = sc.nextInt();
		String str = "";
		for(int i = 0;i < n;i++) {
			str += sc.next();
		}
		char ch[] = str.toCharArray();
		int begin = 0;
		int end = ch.length-1;
		int count = 0;
		while(begin <= end) {
			boolean flag = false;
			for(int i = 0;i+begin <= end;i++) {
				if(ch[begin+i] < ch[end-i]) {
					flag = true;
					count++;
					break;
				}
				else {
					flag = false;
					count++;
					break;
				}
			}
			if(flag) {
				System.out.print(ch[begin++]);
			}
			else {
				System.out.print(ch[end--]);
			}
			if(count%80==0) {
				System.out.println();
			}
		}
		System.out.println();
		sc.close();
	}
}