Time Limit: 1000MS | Memory Limit: 30000K | |
Total Submissions: 9745 | Accepted: 5921 |
Description
Each player chooses two numbers Ai and Bi and writes them on a slip of paper. Others cannot see the numbers. In a given moment all players show their numbers to the others. The goal is to determine the sum of all expressions AiBi from all players including oneself and determine the remainder after division by a given number M. The winner is the one who first determines the correct result. According to the players' experience it is possible to increase the difficulty by choosing higher numbers.
You should write a program that calculates the result and is able to find out who won the game.
Input
Output
(A1B1+A2B2+ ... +AHBH)mod M.
Sample Input
3
16
4
2 3
3 4
4 5
5 6
36123
1
2374859 3029382
17
1
3 18132
Sample Output
2
13195
13
参考代码:
#include<iostream>
#include<stdio.h>
using namespace std;
typedef long long ll;
ll mod_pow(ll x,ll n,ll mod)//快速幂运算
{
ll res=1;
while(n>0)
{
if(n&1)res=res*x%mod;
x=x*x%mod;
n>>=1;
}
return res;
}
int MOD;
int N;
int A,B;
int main()
{
//freopen("C://Users/Administrator/Desktop/acm.txt","r",stdin);
int test;
cin>>test;
ll ans=0;
while(test--)
{
ans=0;
cin>>MOD>>N;
while(N--)
{
cin>>A>>B;
ans=(ans+mod_pow(A,B,MOD))%MOD;
}
cout<<ans<<endl;
}
return 0;
}