RIPV2手工汇总
1、 实验目的:
通过本次实验,我们可以掌握以下技能
1) RIPV2的手工汇总。
2) RIPv2不支持CIDR汇总。
3) RIPv2可以传送CIDR汇总。
2、 实验拓扑图:
3、 实验步骤:
(1) 根据网络拓扑图说明,配置各个接口的地址。
R!(config)#hostname R1
R1(config)#interface loopback 0
R1(config-if)#ip address 1.1.1.1 255.255.255.0
R1(config-if)#no shutdown
R1(config)#interface serial 0/1
R1(config-if)#ip address 192.168.1.1 255.255.255.0
R1(config-if)#no shutdown
R1(config-if)#end
R1#
Router(config)#hostname R2
R2(config)#interface serial 0/1
R2(config-if)#clock rate 128000
R2(config-if)#ip ad
R2(config-if)#ip address 192.168.1.2 255.255.255.0
R2(config-if)#no shutdown
R2(config-if)#end
R2(config)#interface serial 0/2
R2(config-if)#ip address 192.168.2.1 255.255.255.0
R2(config-if)#no shutdown
R2(config-if)#
Router(config)#hostname R3
R3(config)#interface serial 0/2
R3(config-if)#ip ad
R3(config-if)#ip address 192.168.2.2 255.255.255.0
R3(config-if)#clock rate 128000
R3(config-if)#no shutdown
R3(config-if)#exit
R3(config)#interface serial 0/3
R3(config-if)#ip address 192.168.3.1 255.255.255.0
R3(config-if)#no shutdown
R3(config-if)#
R4(config)#interface serial 0/3
R4(config-if)#ip address 192.168.3.2 255.255.255.0
R4(config-if)#no shutdown
R4(config-if)#exit
R4(config)#interface loopback 0
R4(config-if)#ip address 4.4.0.4 255.255.255.0
R4(config-if)#exit
R4(config)#interface loopback 1
R4(config-if)#ip ad
R4(config-if)#ip address 4.4.1.4 255.255.255.0
R4(config-if)#no shutdown
R4(config-if)#exit
R4(config)#interface loopback 2
R4(config-if)#ip address 4.4.2.4 255.255.255.0
R4(config-if)#no shutdown
R4(config-if)#exit
R4(config)#interface loopback 3
R4(config-if)#ip address 4.4.3.4 255.255.255.0
R4(config-if)#no shutdown
R4(config-if)#
(2) 启用RIPv2,关闭自动汇总,我们进行手工汇总。
R1(config)#router rip
R1(config-router)#version 2
R1(config-router)#no au
R1(config-router)#no auto-summary
R1(config-router)#net
R1(config-router)#network 1.0.0.0
R1(config-router)#network 192.1681.0
R1(config-router)#network 192.168.1.0
R2(config)#router rip
R2(config-router)#ver
R2(config-router)#version 2
R2(config-router)#no auto-summary
R2(config-router)#network 192.168.1.0
R2(config-router)#network 192.168.2.0
R2(config-router)#
R3(config)#router rip
R3(config-router)#version 2
R3(config-router)#network 192.168.2.0
R3(config-router)#network 192.168.3.0
R3(config-router)#
R4(config)#router rip
R4(config-router)#version 2
R4(config-router)#no auto-summary
R4(config-router)#network 192.168.3.0
R4(config-router)#network 4.0.0.0
R4(config-router)#exit
R4(config)#interface serial 0/3
R4(config-if)#ip summary-address r
R4(config-if)#ip summary-address rip 4.4.0.0 255.255.252.0
R4(config-if)#
(3) 在没有进行汇总之前,我们可以看到R1的路由表如下所示:
R1#show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route
Gateway of last resort is not set
C 1.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
1.0.0.0/8 [120/2] via 192.168.2.1, 00:00:01, Serial0/1
R 1.1.1.0/24 [120/2] via 192.168.2.1, 00:03:17, Serial0/1
4.0.0.0/24 is subnetted, 4 subnets
R 4.4.0.0 [120/1] via 192.168.3.2, 00:00:12, Serial0/2
R 4.4.1.0 [120/1] via 192.168.3.2, 00:00:12, Serial0/2
R 4.4.2.0 [120/1] via 192.168.3.2, 00:00:12, Serial0/2
R 4.4.3.0 [120/1] via 192.168.3.2, 00:00:12, Serial0/2
R 192.168.1.0/24 [120/1] via 192.168.2.1, 00:00:01, Serial0/1
C 192.168.2.0/24 is directly connected, Serial0/1
R 192.168.3.0/24 is directly connected, Serial0/2
R1#
从上面可以看出,路由器R1中有4条R4的路由。
在汇总之后,我们又可以看到路由器的汇总如下:
R1#show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route
Gateway of last resort is not set
1.0.0.0/24 is subnetted, 1 subnets
C 1.1.1.0 is directly connected, Loopback0
R 4.0.0.0/8 [120/3] via 192.168.1.2, 00:00:05, Serial0/0
C 192.168.1.0/24 is directly connected, Serial0/0
R 192.168.2.0/24 [120/1] via 192.168.1.2, 00:00:05, Serial0/0
R 192.168.3.0/24 [120/2] via 192.168.1.2, 00:00:05, Serial0/0
R1#
上面输出表明,在路由器上已经接收到了路由汇总。
接下来我们在R4上做如下配置:
R4(config)#interface loopback 0
R4(config-if)#ip address 192.168.96.4 255.255.255.0
R4(config-if)#no shutdown
R4(config-if)#exit
R4(config)#interface loopback 1
R4(config-if)#ip address 192.168.97.4 255.255.255.0
R4(config-if)#no shutdown
R4(config-if)#exit
R4(config)#interface loopback 2
R4(config-if)#ip address 192.168.98.4 255.255.255.0
R4(config-if)#no shutdown
R4(config-if)#exit
R4(config)#interface loopback 3
R4(config-if)#ip address 192.168.99.4 255.255.255.0
R4(config-if)#no shutdown
R4(config-router)#version 2
R4(config-router)#network 192.168.96.0
R4(config-router)#network 192.168.97.0
R4(config-router)#network 192.168.98.0
R4(config-router)#network 192.168.99.0
R4(config-router)#exit
R4(config)#interface serial 0/2
R4(config-if)#ip su
R4(config-if)#ip summary-address r
R4(config-if)#ip summary-address rip 192.168.96.0 255.255.252.0
Summary mask must be greater or equal to major net
注:在进行汇总的时候,路由器会提示“Summary mask must be greater or equal to major net
”此信息,此信息表明汇总后掩码的长度必须大于或等于主类网络的掩码的长度,因为22<24,所有不能汇总。
所以RIPv2不支持CIDR,但是可传输CIDR。
OK 实验到此结束!!!!!!!!!!!!!!!!!!
转载于:https://blog.51cto.com/lorna8023/240098