前言
本文主要给大家介绍了关于利用C/C++如何实现模拟计算器的相关内容,分享出来供大家参考学习,下面话不多说了,来一起看看详细的介绍吧。
Problem Description
简单计算器模拟:输入两个整数和一个运算符,输出运算结果。
Input
第一行输入两个整数,用空格分开;
第二行输入一个运算符(+、-、*、/)。
所有运算均为整数运算,保证除数不包含0。
Output
输出对两个数运算后的结果。
Example Input
1
2
|
30 50
*
|
Example Output
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
|
import java.util.Scanner;
public class Main {
public static void main(String args[]){
Scanner reader = new Scanner(System.in);
int m,n;
String a = "+" ,b = "-" ,c= "*" ,d = "/" ;
String s;
m = reader.nextInt();
n = reader.nextInt();
s = reader.next();
switch (s){
case "+" :System.out.println(m+n); break ;
case "-" :System.out.println(m-n); break ;
case "*" :System.out.println(m*n); break ;
case "/" :
System.out.println(m/n);
break ;
}
}
}
|
总结
以上就是这篇文章的全部内容了,希望本文的内容对大家的学习或者工作具有一定的参考学习价值,如果有疑问大家可以留言交流,谢谢大家对服务器之家的支持。
原文链接:http://blog.csdn.net/jia1506/article/details/70339488