计算该日在本年中是第几天

时间:2021-06-08 01:24:40

Problem H: 计算该日在本年中是第几天

Time Limit: 1 Sec   Memory Limit: 128 MB

Submit: 1075  

Solved: 718

[

Submit][

Status][

Web Board]


Description


定义一个结构体变量(包括年、月、日)。计算该日在本年中是第几天,注意闰年问题。


Input


年月日


Output


当年第几天


Sample Input

2000 12 31

Sample Output

366

HINT


[ Submit][

Status][

Web Board]


한국어 中文 فارسی English ไทย
Anything about the Problems, Please Contact Admin:admin
All Copyright Reserved 2010-2014 HUSTOJ TEAM
GPL2.0 2003-2014 HUSTOJ Project TEAM
Help Maunal

代码

#include <iostream>
#include <cstdio>
#include <cstdlib>
using namespace std ;
typedef struct Days{
	int year ;
	int month ;
	int day ;
}Day;
int solve(Day a)
{
	int B[13] = {0 ,31 ,28 , 31, 30 ,31,30,31,31,30,31,30,31};
	int i , j ;
	int sum = 0 ;
	if(a.year %4==0 &&a.year%100!=0 || a.year%400==0)
	{
		B[2]++ ;
	}
	for(i= 1;i<=12 ;i++)
	{
		if(i == a.month)
		{
			break ;
		}
		sum+=B[i] ;

	}
	return sum+a.day ;

}
int main()
{
	int i ;
	Day a ;
	cin>>a.year >>a.month >>a.day ;
cout<<	solve(a);


	return 0 ;
}