
18:验证子串
- 总时间限制:
- 1000ms
- 内存限制:
- 65536kB
- 描述
-
输入两个字符串,验证其中一个串是否为另一个串的子串。
- 输入
- 输入两个字符串, 每个字符串占一行,长度不超过200且不含空格。
- 输出
- 若第一个串s1是第二个串s2的子串,则输出(s1) is substring of (s2)
否则,若第二个串s2是第一个串s1的子串,输出(s2) is substring of (s1)
否则,输出 No substring。 - 样例输入
-
abc
dddncabca - 样例输出
-
abc is substring of dddncabca
- 来源
- JerryCircle[Java 语言程序设计]
思路:
大模拟;
来,上代码:
#include<cstdio>
#include<string>
#include<cstring>
#include<algorithm> using namespace std; char word_1[],word_2[]; int main()
{
gets(word_1);
gets(word_2);
if(strstr(word_1,word_2)!=NULL)
{
printf("%s is substring of %s\n",word_2,word_1);
return ;
}
if(strstr(word_2,word_1)!=NULL)
{
printf("%s is substring of %s\n",word_1,word_2);
return ;
}
printf("No substring\n");
return ;
}