链接:http://poj.org/problem?id=1384
Time Limit: 1000MS | Memory Limit: 10000K | |
Total Submissions: 8893 | Accepted: 4333 |
Description
Whenever some ACM member has any small money, he takes all the coins and throws them into a piggy-bank. You know that this process is irreversible, the coins cannot be removed without breaking the pig. After a sufficiently long time, there should be enough
cash in the piggy-bank to pay everything that needs to be paid.
But there is a big problem with piggy-banks. It is not possible to determine how much money is inside. So we might break the pig into pieces only to find out that there is not enough money. Clearly, we want to avoid this unpleasant situation. The only possibility
is to weigh the piggy-bank and try to guess how many coins are inside. Assume that we are able to determine the weight of the pig exactly and that we know the weights of all coins of a given currency. Then there is some minimum amount of money in the piggy-bank
that we can guarantee. Your task is to find out this worst case and determine the minimum amount of cash inside the piggy-bank. We need your help. No more prematurely broken pigs!
Input
an empty pig and of the pig filled with coins. Both weights are given in grams. No pig will weigh more than 10 kg, that means 1 <= E <= F <= 10000. On the second line of each test case, there is an integer number N (1 <= N <= 500) that gives the number of
various coins used in the given currency. Following this are exactly N lines, each specifying one coin type. These lines contain two integers each, Pand W (1 <= P <= 50000, 1 <= W <=10000). P is the value of the coin in monetary units, W is it's weight in
grams.
Output
using coins with the given total weight. If the weight cannot be reached exactly, print a line "This is impossible.".
Sample Input
3
10 110
2
1 1
30 50
10 110
2
1 1
50 30
1 6
2
10 3
20 4
Sample Output
The minimum amount of money in the piggy-bank is 60.
The minimum amount of money in the piggy-bank is 100.
This is impossible.
题意:如今有n种硬币,每种硬币有特定的重量cost[i] 克和它相应的价值val[i]. 每种硬币能够无限使用. 已知如今一个储蓄罐中所有硬币的总重量正好为m克, 问你这个储蓄罐中最少有多少价值的硬币? 假设不可能存在m克的情况, 那么就输出” This is impossible.”.
分析:这是一题全然背包题目。 本题的限制条件: 硬币总重量正好等于m. 本题的目标条件:
硬币总价值尽量小.初始化时dp[0]==0,(由于本题要求的是最小的价值,所以其它应该所有初始化为INF,假设求最大值则初始化为-1.)。
状态转移方程:dp[j]=min(dp[j],dp[j-r[i].w]+r[i].value).
<span style="font-size:18px;">#include<iostream>
#include<cstdio>
#include<cmath>
#include<cstring>
#define INF 0x7fffffff
using namespace std;
const int maxn=10010;
struct node{
int value;
int w;
}r[maxn];
int dp[10010];
int main()
{
int t,k;
int E,F,v;
scanf("%d",&t);
while(t--)
{
scanf("%d %d",&E,&F);
scanf("%d",&k);
for(int i=1;i<=k;i++)
{
scanf("%d %d",&r[i].value,&r[i].w);
}
v=F-E;
dp[0]=0;
for(int i=1;i<=v;i++) dp[i]=INF;
for(int i=1;i<=k;i++)
{
for(int j=r[i].w;j<=v;j++)
{
if(dp[j-r[i].w] != INF)
dp[j]=min(dp[j-r[i].w]+r[i].value,dp[j]);
}
/*for(int i=1;i<=v;i++) cout<< dp[i] << " ";
cout<<endl;*/
}
if(dp[v] != INF)
printf("The minimum amount of money in the piggy-bank is %d.\n",dp[v]);
else
printf("This is impossible.\n");
}
return 0;
}
</span>