
Find The Multiple
Time Limit: 1000MS | Memory Limit: 10000K | |||
Total Submissions: 22576 | Accepted: 9291 | Special Judge |
Description
Given a positive integer n, write a program to find out a nonzero multiple m of n whose decimal representation contains only the digits 0 and 1. You may assume that n is not greater than 200 and there is a corresponding m containing no more than 100 decimal digits.
Input
The input file may contain multiple test cases. Each line contains a value of n (1 <= n <= 200). A line containing a zero terminates the input.
Output
For each value of n in the input print a line containing the corresponding value of m. The decimal representation of m must not contain more than 100 digits. If there are multiple solutions for a given value of n, any one of them is acceptable.
Sample Input
2
6
19
0
Sample Output
10
100100100100100100
111111111111111111
题目大意:找到n的一个倍数,并且这个数只由0 1组成。
#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;
int n;
bool flag;
unsigned long long m;
void dfs(unsigned long long x,int k)
{
cout<<x<<endl;
if(flag)
return;
if(x%n==)
{
flag=;
m=x;
return;
}
if(k==)
return;
dfs(x*,++k);
dfs(x*+,k);
return;
}
int main()
{
int i,j;
while(cin>>n&&n)
{
flag=;
dfs(,);
cout<<m<<endl;
}
}